Bug 133804 - vim: defaults to colors suited to light backgrounds (should be dark)
Summary: vim: defaults to colors suited to light backgrounds (should be dark)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: vim   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-27 16:58 UTC by Zack Cerza
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 10:36:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zack Cerza 2004-09-27 16:58:55 UTC
Description of problem:
The default vim install uses colors suited to light backgrounds, which
is a pretty rare case. Could we change the default?

# diff -u /etc/vimrc.rpmnew /etc/vimrc
--- /etc/vimrc.rpmnew   2004-09-21 06:59:14.000000000 -0400
+++ /etc/vimrc  2004-09-27 12:49:05.887773280 -0400
@@ -10,6 +10,7 @@
                        " than 50 lines of registers
 set history=50         " keep 50 lines of command line history
 set ruler              " show the cursor position all the time
+set bg=dark            " use colors suitable for dark backgrounds
 
 " Only do this part when compiled with support for autocommands
 if has("autocmd")

Version-Release number of selected component (if applicable):
vim-common-6.3.028-1

Comment 1 Karsten Hopp 2004-09-27 18:36:19 UTC
I don't agree with your statement that people prefering light 
backgrounds are rare. Taking a look around in our office at other 
peoples vim sessions, light backgrounds are actually way more common 
then dark backgrounds. 
It's a difficult task to make everyone happy. Maybe I should try to 
get help on fedora-devel to test all color schemes from 
http://www.vim.org/scripts/script.php?script_id=625 with light and 
dark backgrounds, but I'm tempted to close this as "won't fix" 

Comment 2 Zack Cerza 2004-09-27 19:49:20 UTC
I wasn't stating or implying that people prefer light or dark backgrounds.

gvim always uses a light background, if your gtk themes does. The
linux console always uses a black background. X users can use gvim,
but console users can't. I just think the console default should be
friendly to console users, since the X default is always friendly to X
users.

(there's no magic way for vim to know what its fore/background colors
for "normal" text are and make a decision based on that, is there?)

Comment 3 Karsten Hopp 2004-09-29 10:36:54 UTC
vim already checks the environment and automatically uses bg=dark on 
the console. Edit a .c file which using the console (.c only to see 
the highlight colors) and try to switch to bg=dark. You'll see that 
nothing changes, whereas switching to bg=light will result in some 
different colors. 


Note You need to log in before you can comment on or make changes to this bug.