Bug 1338198 - corebird incorrectly removes sqlite-libs when uninstalling
Summary: corebird incorrectly removes sqlite-libs when uninstalling
Status: CLOSED DUPLICATE of bug 1259865
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 23
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-21 18:17 UTC by Gerald Cox
Modified: 2016-05-24 01:20 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-05-24 01:20:43 UTC


Attachments (Terms of Use)

Description Gerald Cox 2016-05-21 18:17:30 UTC
Description of problem:
corebird incorrectly removes sqlite-libs when uninstalling

Version-Release number of selected component (if applicable):
1.2.1-1.fc23

How reproducible:
dnf remove corebird


Steps to Reproduce:
1. dnf remove corebird
2.
3.

Actual results:
# dnf remove corebird
Dependencies resolved.
Removing:
 corebird                  x86_64               1.2.1-1.fc23                   @updates               1.9 M
 sqlite-libs               x86_64               3.11.0-3.fc23                  @updates               879 k
Remove  2 Packages


Expected results:
Only remove corebird - DO NOT remove sqlite-libs

Additional info:
Removal of sqlite-libs causes rpm and dnf to break (among other things) and is a complete foobar to recover.
This needs to be fixed immediately.

Comment 1 Gerald Cox 2016-05-21 18:27:00 UTC
For those of you who are unfortunate enough to encounter this error:

Download both packages into a new directory and then run these commands:

rpm2cpio sqlite-3.11.0-1.fc23.x86_64.rpm | cpio -idmv
rpm2cpio sqlite-libs-3.11.0-1.fc23.x86_64.rpm |cpio -idmv
sudo cp -R usr/ /
sudo dnf --best --allowerasing install sqlite

Comment 2 Michael Catanzaro 2016-05-23 22:55:39 UTC
Reassigning to dnf for triage. At the risk of stating the obvious, sqlite-libs does not depend on corebird.

Comment 3 Samuel Sieb 2016-05-23 23:04:31 UTC
This cannot be a problem with the corebird package, because sqlite-libs does not depend on corebird, so removing corebird can't force sqlite-libs to be uninstalled.

This means that dnf must consider sqlite-libs to be a dependency that isn't needed any more.  As far as I can tell, rpm does not require sqlite.  Dnf does, but not directly.  The dependency chain there goes through python to python-libs which requires libsqlite3.so.0().

It appears that at some point during the F23 cycle, sqlite was split into two packages, sqlite and sqlite-libs.  This means that the package that provides libsqlite3.so.0() has changed from sqlite to sqlite-libs.

Do you have the 32-bit version of sqlite-libs installed as well?  The sqlite package has a dependency on sqlite-libs with no bit size.  However, that still doesn't explain why python (along with a lot of other packages) wouldn't have kept it in because that has an arch dependency.  The only other package that provides that is the original sqlite package and that should not be installed still.

Comment 4 Gerald Cox 2016-05-23 23:50:27 UTC
(In reply to Samuel Sieb from comment #3)
> This cannot be a problem with the corebird package, because sqlite-libs does

> Do you have the 32-bit version of sqlite-libs installed as well?  

Yes, I do:
rpm -qa | grep sqlite-libs
sqlite-libs-3.11.0-3.fc23.x86_64
sqlite-libs-3.11.0-3.fc23.i686

I've installed and uninstalled many packages and have never seen this problem.  So there has to be something with corebird which is triggering it.  That isn't to say that corebird is doing something wrong, but since it is the trigger it should hold the key to the problem.

That said, if this isn't a corebird issue and instead a problem with dnf, that makes it even more serious.  You can't have the package manager uninstalling packages willy nilly.  

Thanks guys for your input and comments!

Comment 5 Gerald Cox 2016-05-24 01:20:43 UTC
Kevin Fenzi replied to the mailing list that this may be a duplicate of bug 1259865.  I reinstalled sqlite-libs and the problem was resolved - so looks like it indeed is... closing and marking as duplicate.

*** This bug has been marked as a duplicate of bug 1259865 ***


Note You need to log in before you can comment on or make changes to this bug.