Bug 133834 - Hal thinks my camera is two floppy disks
Hal thinks my camera is two floppy disks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-27 16:01 EDT by Kyrre Ness Sjøbæk
Modified: 2013-03-05 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 07:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
catproclog (240 bytes, text/plain)
2004-09-27 17:12 EDT, Kyrre Ness Sjøbæk
no flags Details
haldebuglog (52.17 KB, text/plain)
2004-09-27 17:14 EDT, Kyrre Ness Sjøbæk
no flags Details
lshallog (28.56 KB, text/plain)
2004-09-27 17:15 EDT, Kyrre Ness Sjøbæk
no flags Details
treelog (30.36 KB, text/plain)
2004-09-27 17:15 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2004-09-27 16:01:48 EDT
Description of problem:
When i plug in my camera, hal sets up two new montpoints which get
automagically mounted. And when i remove the camera (it is an usb mass
storage device), it gets unmounted and the mountpoints removed. Nice.

Only problem is:
-Two mountpoints get created, for both sda and sda1 - and only sda1 is
needed. So why create two mountpoints?
-It is not a floppy, but a camera!

Version-Release number of selected component (if applicable):
hal-0.2.98.cvs20040923-1

How reproducible:
Every time

Steps to Reproduce:
1. Plug in an usb mass storage device (at least my camera)
2.
3.
  
Actual results:
Two mountpoints get created

Expected results:
One mounpoint called something else than "floppy" gets created. USB,
maybe?

Additional info:
fstab when camera plugged in:
/dev/VolGroup00/LogVol00 /         ext3    defaults        1 1
LABEL=/boot              /boot     ext3    defaults        1 2
none                     /dev/pts  devpts  gid=5,mode=620  0 0
none                     /dev/shm  tmpfs   defaults        0 0
none                     /proc     proc    defaults        0 0
none                     /sys      sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap      swap    defaults        0 0
192.168.0.200:/home/kyrre /mnt/nfs nfs     user            0 0
/dev/hdc       /media/cdrom auto noauto,user,exec,kudzu,ro 0 0
/dev/fd0             /media/floppy  auto noauto,user,exec,kudzu 0 0
/dev/sda             /media/floppy1 auto noauto,user,exec,kudzu 0 0
/dev/sda1 /media/floppy2 vfat noauto,user,exec,kudzu,noatime,sync 0 0
Comment 1 David Zeuthen 2004-09-27 16:20:15 EDT
Ok, I need the following

1. the output from 'hald --daemon=no --verbose=yes' from after the
"Device Probing Completed" line (one of the very last lines on hald
startup) and from when you have hotplugged your camera.

2. The output from lshal when the camera is attached and powered up

3. The output from 'tree /sys' when the camera is attached and powered
up (you may need to 'yum install tree')

4. The output of 'cat /proc/scsi/usb-storage/<number>' with <number>
being probably the only file in that directory

I think the heuristic hal uses to detect a USB floppy drive may need
to be revisited.

Thanks,
David
Comment 2 Kyrre Ness Sjøbæk 2004-09-27 17:07:05 EDT
okay. This is what i did:

- start hald.

- power the cam up

- run lshal > lshallog

- install tree :) (me loooves the new yum)

- run tree /sys > treelog

- cat /proc/scsi/usb-storage/8 > catproclog

- power down camera

- stop hald with control+c

- go submit the logs
Comment 3 Kyrre Ness Sjøbæk 2004-09-27 17:12:46 EDT
Created attachment 104401 [details]
catproclog
Comment 4 Kyrre Ness Sjøbæk 2004-09-27 17:14:22 EDT
Created attachment 104402 [details]
haldebuglog
Comment 5 Kyrre Ness Sjøbæk 2004-09-27 17:15:02 EDT
Created attachment 104403 [details]
lshallog
Comment 6 Kyrre Ness Sjøbæk 2004-09-27 17:15:29 EDT
Created attachment 104404 [details]
treelog
Comment 7 Kyrre Ness Sjøbæk 2004-09-27 17:17:40 EDT
Hmm... forgot to "filter" haldebuglog. Bet you can do that yourself.

Good night - its 23:15 here and i am tired of having sqatted bugs
since 12:00

RH should have payed me for sqatting bugs.

*cantwait for FC3*
Comment 8 David Zeuthen 2004-09-27 17:27:22 EDT
Ok, this is an easy fix - hal should really just look at the usb
interface class. Your device reports the class tripplet (8, 5, 0)
while my USB floppy drive reports (8, 4, 0). According to this snippet
from file:///usr/share/hwdata/usb.ids 

C 08  Mass Storage
        01  RBC (typically Flash)
                00  Control/Bulk/Interrupt
                01  Control/Bulk
                50  Bulk (Zip)
        02  SFF-8020i, MMC-2 (ATAPI)
        03  QIC-157
        04  Floppy (UFI)
                00  Control/Bulk/Interrupt
                01  Control/Bulk
                50  Bulk (Zip)
        05  SFF-8070i
        06  SCSI
                00  Control/Bulk/Interrupt
                01  Control/Bulk
                50  Bulk (Zip)

hal should just tag all devices with protocol=8, subprotocol=4 as
floppies. Today we just look at the "     Protocol: Uniform Floppy
Interface (UFI)" line in /proc/scsi/usb-storage/number which is a bug
as this report shows.

Thanks for filing this bug; it will be fixed in the next update.
Comment 9 Kyrre Ness Sjøbæk 2004-09-29 12:07:55 EDT
Hmm... I updated hal to hal-0.2.98.cvs20040927-1 - and it STILL thinks
it is two (wrong - only sda1 should be mounted) floppy (wrong - its
not a floppy, but the biggest problem is that there is created two of
them) disk. Only difference is that they refuse to mount it
automatically now.
Comment 10 David Zeuthen 2004-09-29 12:12:05 EDT
It's fixed in upstream CVS (today) but not yet in Rawhide. Will upload
a new package later today. Comment 8 was written after the
hal-0.2.98.cvs20040927-1 was uploaded.

David
Comment 11 Kyrre Ness Sjøbæk 2004-10-03 07:40:47 EDT
Forgot to tell you - it works like a charm now :)

No reason not to close this now.

Note You need to log in before you can comment on or make changes to this bug.