Bug 133838 - udev tries to load floppy.ko for non-existant drive
udev tries to load floppy.ko for non-existant drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-27 16:21 EDT by Jason
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: udev-032-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 05:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2004-09-27 16:21:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040926
Firefox/0.10

Description of problem:
Udev tries to load the floppy.ko module when I do not have a floppy
drive.  This produces an error when udev is started: FATEL: error
inserting floppy



Version-Release number of selected component (if applicable):
udev-032-2

How reproducible:
Always

Steps to Reproduce:
1.  Start udev on a PC that does not have a floppy drive
2.
3.
    

Actual Results:  tried to load module and error message

Expected Results:  it should not have tried to load the floppy module
thus no error message

Additional info:
Comment 1 Bill Nottingham 2004-09-28 12:27:54 EDT
You can't probe for the presence of a floppy without loading a floppy
driver.
Comment 2 Jason 2004-09-28 12:47:23 EDT
Then how about getting rid of the error message?
Comment 3 Bill Nottingham 2004-09-28 12:54:36 EDT
It does.

modprobe floppy >/dev/null 2>&1
Comment 4 Bill Nottingham 2004-09-28 12:59:01 EDT
Oh, I see where this is coming from now.

udev manually creates /dev/fdX on start.

Hence, any attempt to access them causes an autoload of floppy, which
may or many not succeed.

Since we're loading floppy in rc.sysinit, I don't think the manual
udev creation is needed.
Comment 5 Jason 2004-09-28 13:03:16 EDT
Thank you for the update.  I await an update for testing.

Note You need to log in before you can comment on or make changes to this bug.