Bug 133840 - htdig will not run
htdig will not run
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: htdig (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
RHEL3U7NAK
:
Depends On:
Blocks: 189875
  Show dependency treegraph
 
Reported: 2004-09-27 16:27 EDT by Daniel Fisher
Modified: 2013-04-30 19:33 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0026
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:48:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
BDB __os_fileid fix for 64-bit platforms (1.34 KB, patch)
2005-01-20 09:08 EST, Joe Orton
no flags Details | Diff

  None (edit)
Description Daniel Fisher 2004-09-27 16:27:04 EDT
Description of problem:
*** Audit: FIRSTCITIZENS  21-SEP-2004 12:37:34  Group Type:          
 --> Group Resource
*** Notes: FIRSTCITIZENS  21-SEP-2004 12:37:34
[root@linx01 etc]# rundig 
htdig: Unable to open/create document database '/var/lib/htdig/db.docdb' 
  
htmerge: Unable to open word list file '/var/lib/htdig/db.wordlist'. 
  Did you index anything? 
  Check your config file and try running htdig again. 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge?
*** Audit: FIRSTCITIZENS  21-SEP-2004 12:37:34  Group:               
 --> Web
*** Notes: FIRSTCITIZENS  21-SEP-2004 12:37:35
File htdig attached




*** Audit: DFISHER@REDHAT.COM  21-SEP-2004 12:58:14  Owner:          
      --> Fisher Daniel
*** Audit: DFISHER@REDHAT.COM  21-SEP-2004 12:58:14  Owner type:     
      --> Employee Resource
*** Audit: DFISHER@REDHAT.COM  21-SEP-2004 12:58:14  Status:         
     Open --> Waiting on Customer
*** Notes: DFISHER@REDHAT.COM  21-SEP-2004 12:58:14
Dear Sir,

Thank you for contacting Red Hat Technical Support.

I think that you are running 'rundig' as a non-root user.

You will have better luck running 'rundig' as root.

(Or you could give the user that you are running as permission to
write to the '/var/lib/htdig'... That *might* work)

Thank you for your time,
Daniel Fisher

Thank you for your time,
Dan
*** Interaction: 286319  DFISHER@REDHAT.COM  21-SEP-2004 12:58:14 
Service request updated
*** Interaction: 286319  DFISHER@REDHAT.COM  21-SEP-2004 12:58:14 
Service request updated
*** Audit: FIRSTCITIZENS  21-SEP-2004 14:57:12  Status:              
Waiting on Customer --> Waiting on Technician
*** Notes: FIRSTCITIZENS  21-SEP-2004 14:57:12
as the previously included error messages shows "root@linx01" I was
attempting 
to run htdig as root.
*** Audit: DFISHER@REDHAT.COM  21-SEP-2004 16:22:30  Status:         
     Waiting on Technician --> Waiting on Customer
*** Interaction: 286497  DFISHER@REDHAT.COM  21-SEP-2004 16:22:31 
Service request updated
*** Notes: DFISHER@REDHAT.COM  21-SEP-2004 16:22:31
Dear Sir,

I apologize for missing the fact that you were logged in as root.

Can you run the following command:
rpm -qv htdig
and send me the results?

In addition, can you attach the /etc/htdig.conf file to this ticket?

Thank you for your time,
Daniel Fisher
*** Interaction: 286497  DFISHER@REDHAT.COM  21-SEP-2004 16:22:31 
Service request updated
*** Audit: FIRSTCITIZENS  21-SEP-2004 16:35:17  Status:              
Waiting on Customer --> Waiting on Technician
*** Notes: FIRSTCITIZENS  21-SEP-2004 16:35:17
[root@linx01 root]# rpm -qv htdig 
htdig-3.1.6-3 

*** Notes: FIRSTCITIZENS  21-SEP-2004 16:37:37
File htdig.conf attached

*** Notes: FIRSTCITIZENS  21-SEP-2004 16:37:37
attached /etc/htdig.conf
*** Audit: DFISHER@REDHAT.COM  21-SEP-2004 17:05:17  Status:         
     Waiting on Technician --> Waiting on Customer
*** Interaction: 286527  DFISHER@REDHAT.COM  21-SEP-2004 17:05:17 
Service request updated
*** Notes: DFISHER@REDHAT.COM  21-SEP-2004 17:05:17
Could you run the following command and attach the results:

htdig -vv

Thank you for your time,
Daniel Fisher
*** Interaction: 286527  DFISHER@REDHAT.COM  21-SEP-2004 17:05:18 
Service request updated
*** Audit: FIRSTCITIZENS  22-SEP-2004 07:45:02  Status:              
Waiting on Customer --> Waiting on Technician
*** Notes: FIRSTCITIZENS  22-SEP-2004 07:45:02
[root@linx01 root]# htdig -vv 
htdig: Unable to open/create document database '/var/lib/htdig/db.docdb' 

*** Notes: DFISHER@REDHAT.COM  22-SEP-2004 08:52:20
Dear Sir,

Can you run the command 'ls -slap' in /var/lib/htdig and send me the
results?

[root@linx01 htdig]# ls -slap

Thank you for your time,
Daniel Fisher
*** Audit: DFISHER@REDHAT.COM  22-SEP-2004 08:52:20  Status:         
     Waiting on Technician --> Waiting on Customer
*** Interaction: 286824  DFISHER@REDHAT.COM  22-SEP-2004 08:52:20 
Service request updated
*** Interaction: 286824  DFISHER@REDHAT.COM  22-SEP-2004 08:52:20 
Service request updated
*** Notes: FIRSTCITIZENS  22-SEP-2004 15:38:21
[root@linx01 docs]# ls -slap /var/lib/htdig 
total 12 
   4 drwxr-xr-x    3 root     root         4096 Sep 21 12:31 ./ 
   4 drwxr-xr-x   15 root     root         4096 Sep 20 14:39 ../ 
   4 drwxr-xr-x    2 root     root         4096 Sep 20 14:47 db/ 
   0 -rw-r--r--    1 root     root            0 Sep 21 12:31 db.docdb 
   0 -rw-r--r--    1 root     root            0 Sep 21 12:31
db.wordlist.new 

*** Audit: FIRSTCITIZENS  22-SEP-2004 15:38:21  Status:              
Waiting on Customer --> Waiting on Technician
*** Audit: DFISHER@REDHAT.COM  22-SEP-2004 16:04:12  Status:         
     Waiting on Technician --> Waiting on Customer
*** Notes: DFISHER@REDHAT.COM  22-SEP-2004 16:04:12
Dear Sir,

Let's try deleting the files that are in /var/lib/htdig:

rm -rf /var/lib/htdig/*

Then try running 'rundig -vv'

Thank you for your time,
Daniel Fisher
*** Interaction: 287211  DFISHER@REDHAT.COM  22-SEP-2004 16:04:12 
Service request updated
*** Interaction: 287211  DFISHER@REDHAT.COM  22-SEP-2004 16:04:12 
Service request updated
*** Notes: FIRSTCITIZENS  23-SEP-2004 14:43:57
[root@linx01 root]# rm -rf /var/lib/htdig/* 
[root@linx01 root]# ls -slap /var/lib/htdig/ 
total 8 
   4 drwxr-xr-x    2 root     root         4096 Sep 23 14:43 ./ 
   4 drwxr-xr-x   15 root     root         4096 Sep 20 14:39 ../ 
[root@linx01 root]# rundig -vv 
htdig: Unable to open/create document database '/var/lib/htdig/db.docdb' 
 
htmerge: Unable to open word list file '/var/lib/htdig/db.wordlist'. 
  Did you index anything? 
  Check your config file and try running htdig again. 
 
Preamble text: 
 
 
Postamble text: 
Note: This message will be sent again if you do not change or 
take away the notification of the above mentioned HTML page. 
 
Find out more about the notification service at 
 
    http://www.htdig.org/meta.html 
 
Cheers! 
 
ht://Dig Notification Service 
 
 
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
 
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
 
[root@linx01 root]# 
*** Audit: FIRSTCITIZENS  23-SEP-2004 14:43:57  Status:              
Waiting on Customer --> Waiting on Technician
*** Audit: DFISHER@REDHAT.COM  23-SEP-2004 15:00:54  Status:         
     Waiting on Technician --> Waiting on Customer
*** Notes: DFISHER@REDHAT.COM  23-SEP-2004 15:00:54
Dear Sir,

Can you download the htdig RPM from RHN?

up2date -fui --get htdig

and after that completes run this command:

rpm -Uvh /var/spool/up2date/htdig-3.1.6-3.i386.rpm

And then try htdig again?

Thank you for your time,
Daniel Fisher
*** Interaction: 288055  DFISHER@REDHAT.COM  23-SEP-2004 15:00:54 
Service request updated
*** Interaction: 288055  DFISHER@REDHAT.COM  23-SEP-2004 15:00:54 
Service request updated
*** Notes: FIRSTCITIZENS  23-SEP-2004 15:57:17
I got the same results: 
 
 
[root@linx01 docs]# up2date -fui --get htdig 
  
Fetching all package list for channel: rhel-s390x-as-3... 
######################################## 
  
Fetching package list for channel: rhel-s390x-as-3... 
######################################## 
  
htdig-3.1.6-3.s390x.rpm... 
######################################## 
[root@linx01 docs]# rpm -Uvh /var/spool/up2date/htdig-3.1.6-3.s390x.rpm 
Preparing...               
########################################### [100%] 
        package htdig-3.1.6-3 is already installed 
 
[root@linx01 docs]# rundig 
htdig: Unable to open/create document database '/var/lib/htdig/db.docdb' 
  
htmerge: Unable to open word list file '/var/lib/htdig/db.wordlist'. 
  Did you index anything? 
  Check your config file and try running htdig again. 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 

*** Audit: FIRSTCITIZENS  23-SEP-2004 15:57:17  Status:              
Waiting on Customer --> Waiting on Technician
*** Audit: DFISHER@REDHAT.COM  23-SEP-2004 16:02:11  Status:         
     Waiting on Technician --> Waiting on Customer
*** Interaction: 288123  DFISHER@REDHAT.COM  23-SEP-2004 16:02:11 
Service request updated
*** Interaction: 288123  DFISHER@REDHAT.COM  23-SEP-2004 16:02:11 
Service request updated
*** Notes: DFISHER@REDHAT.COM  23-SEP-2004 16:02:11
It looks like the recently downloaded version wasn't installed. (I
apologize for giving you bad instructions)

Try this:
rpm -Uvh --force /var/spool/up2date/htdig-3.1.6-3.i386.rpm

Thank you for your time,
Daniel Fisher
*** Audit: FIRSTCITIZENS  23-SEP-2004 17:00:14  Status:              
Waiting on Customer --> Waiting on Technician
*** Notes: FIRSTCITIZENS  23-SEP-2004 17:00:14
Same thing: 
 
[root@linx01]# rpm -Uvh --force
/var/spool/up2date/htdig-3.1.6-3.s390x.rpm 
Preparing...               
########################################### [100%] 
   1:htdig                 
########################################### [100%] 
[root@linx01]# rundig 
htdig: Unable to open/create document database '/var/lib/htdig/db.docdb' 
  
htmerge: Unable to open word list file '/var/lib/htdig/db.wordlist'. 
  Did you index anything? 
  Check your config file and try running htdig again. 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
  
htfuzzy: Unable to read word database file '/var/lib/htdig/db.words.db' 
Did you run htmerge? 
 
[root@linx01]# ls -l /var/lib/htdig 
total 0 
-rw-r--r--    1 root     root            0 Sep 23 16:57 db.docdb 
-rw-r--r--    1 root     root            0 Sep 23 16:57 db.wordlist.new 

*** Audit: DFISHER@REDHAT.COM  23-SEP-2004 17:24:05  Status:         
     Waiting on Technician --> Waiting on Customer
*** Notes: DFISHER@REDHAT.COM  23-SEP-2004 17:24:05
Dear Sir,

I apologize.

I have given a best-effort to make this work.

The htdig utility is unfortunately not covered by the SLA:
https://www.redhat.com/support/service/sla/rhel3.html

Thank you for your time,
Daniel Fisher



Version-Release number of selected component (if applicable):
htdig-3.1.6-3.s390x

How reproducible:
For customer, all the time...
For tech, isn't a problem

Steps to Reproduce:
1. run 'rundig'
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phil Knirsch 2004-10-20 12:34:35 EDT
I am able to reproduce this bug finally on 64 bit archs like x86_64
and s390x.

I've already scheduled a htdig errata for the next quarterly update
and hope to be able to fix this bug til then.

Will keep the status here in this bz.

Read ya, Phil
Comment 2 Justin Erenkrantz 2004-11-21 04:08:41 EST
Any update on this?  htdig doesn't work on ia64 either.
Comment 3 First Citizens Bank 2004-12-22 14:20:25 EST
Any progress on this item?
Comment 4 Joe Orton 2005-01-20 08:50:06 EST
The bug is due to __os_fileid failing in the ancient BDB-2.6.4 sources
bundled with htdig:

        /* Check for the unthinkable. */
        if (sizeof(sb.st_ino) +
            sizeof(sb.st_dev) + sizeof(time_t) > DB_FILE_ID_LEN)
                return (EINVAL);

where 8 + 8 + 8 > 20 and the "unthinkable" happens.  Newer BDBs have
an __os_fileid which copes with this.
Comment 5 Phil Knirsch 2005-01-20 08:55:54 EST
Excelent catch, Joe!

Do you have a suggestion on how to fix it, too? Because i think
including a newer BDB version won't be easy...

Read ya, Phil
Comment 6 Joe Orton 2005-01-20 09:08:12 EST
Created attachment 110009 [details]
BDB __os_fileid fix for 64-bit platforms

Here's a slightly ugly workaround for __os_fileid on 64-bit platforms, which
maintains exactly the same behaviour on 32-bit platforms, though I'm not sure
if that is actually necessary.

This needs to be properly regression tested across upgrades on 32-bit
platforms.
Comment 28 Red Hat Bugzilla 2007-06-11 14:48:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0026.html

Note You need to log in before you can comment on or make changes to this bug.