Bug 1338504 - dnf upgrade (to 1.1.9) broke bash completion
dnf upgrade (to 1.1.9) broke bash completion
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
: 1339757 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-22 03:30 EDT by Štefan Gurský
Modified: 2016-08-27 06:21 EDT (History)
11 users (show)

See Also:
Fixed In Version: dnf-1.1.10-1.fc24 dnf-1.1.10-1.fc23 dnf-1.1.10-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-19 15:51:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf.log (62.39 KB, text/plain)
2016-05-23 06:33 EDT, Kostya Vasilyev
no flags Details

  None (edit)
Description Štefan Gurský 2016-05-22 03:30:34 EDT
Description of problem:
After upgrading to 1.1.9 I found out that autocompletion in bash does not work sa expected. For example

Typing

  dnf inst

and pressing TAB should complete word install. Instead it does not and second TAB shows the following list:

a              at             DNF            functions.     install        of             part           release.       the            use            
and            available      documentation  api.html.      is             officially     Please         removed        The            will           
API            be             function       in             not            only           'plugins'      supported      upcoming       


Version-Release number of selected component (if applicable):
Name        : dnf
Version     : 1.1.9
Release     : 1.fc23
Architecture: noarch


Steps to Reproduce:
1. open bash
2. type dnf inst
3. press tab (twice) to complete word

Actual results:
Shows list of words that apparently comes from some warning.

Expected results:
autocompletes to install

Additional info:
After downgrade (“dnf downgrade dnf --allowerasing” → 1.1.3) this works as expected.
Comment 1 Michal Luscon 2016-05-23 04:40:56 EDT
Please attach your /var/log/dnf.log .
Comment 2 Kostya Vasilyev 2016-05-23 06:33:02 EDT
Also seeing this after the following upgrades:

Upgrading:
 dnf                                                    noarch                      1.1.9-1.fc23                         updates                      276 k
 dnf-conf                                               noarch                      1.1.9-1.fc23                         updates                       96 k
 dnf-plugin-system-upgrade                              noarch                      0.7.1-1.fc23                         updates                       49 k
 dnf-plugins-core                                       noarch                      0.1.21-1.fc23                        updates                       40 k
 dnf-yum                                                noarch                      1.1.9-1.fc23                         updates                       79 k
 python2-dnf                                            noarch                      1.1.9-1.fc23                         updates                      444 k
 python2-dnf-plugin-system-upgrade                      noarch                      0.7.1-1.fc23                         updates                       31 k
 python3-dnf                                            noarch                      1.1.9-1.fc23                         updates                      448 k
 python3-dnf-plugin-system-upgrade                      noarch                      0.7.1-1.fc23                         updates                       31 k
 python3-dnf-plugins-core                               noarch                      0.1.21-1.fc23                        updates                       93 k

Downgrading to dnf 1.1.3 as in original post (which also downgraded a bunch of deps) did resolve the issue for me too.

dnf update back to 1.1.9 made it come back.

Attaching my dnf.log (although it does not seem to have anything interesting...)
Comment 3 Kostya Vasilyev 2016-05-23 06:33 EDT
Created attachment 1160516 [details]
dnf.log
Comment 4 Christopher Tubbs 2016-05-24 01:03:20 EDT
I am also seeing this with trying to autocomplete "sudo dnf upg"
Comment 5 Kamil Páral 2016-05-24 04:47:31 EDT
I can reproduce with dnf-1.1.9-1.fc24.noarch:

$ sudo dnf distro
a              be             functions.     of             'plugins'      The
and            distro-sync    api.html.      officially     release.       upcoming
API            DNF            in             only           removed        use
at             documentation  is             part           supported      will
available      function       not            Please         the            

Please notice that "distro-sync" is listed, and the rest is some sentence about deprecation.

(In reply to Michal Luscon from comment #1)
> Please attach your /var/log/dnf.log .

Michal, why do you need dnf.log? This is a problem before you even execute dnf, so there's nothing written into dnf.log (I tried, the file is not touched while using the bash-completion).
Comment 6 Štefan Gurský 2016-05-28 05:55:59 EDT
It seems to me that dnf-1.1.9-2.fc23 fixed this.
Comment 7 Honza Silhan 2016-05-30 07:36:30 EDT
*** Bug 1339757 has been marked as a duplicate of this bug. ***
Comment 8 Kamil Páral 2016-05-31 08:03:14 EDT
(In reply to Štefan Gurský from comment #6)
> It seems to me that dnf-1.1.9-2.fc23 fixed this.

Confirmed.
Comment 9 Fedora Update System 2016-08-18 11:19:06 EDT
dnf-1.1.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 10 Fedora Update System 2016-08-18 11:20:21 EDT
dnf-1.1.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 11 Fedora Update System 2016-08-18 11:21:24 EDT
dnf-1.1.10-1.fc24 dnf-plugins-core-0.1.21-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 12 Fedora Update System 2016-08-18 12:52:36 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 13 Fedora Update System 2016-08-18 20:22:24 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 14 Fedora Update System 2016-08-18 20:57:37 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 15 Fedora Update System 2016-08-19 15:50:29 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-08-23 11:19:36 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2016-08-27 06:20:35 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.