Bug 1338522 - REST-API | Missing '/' in HostNIC labels link
Summary: REST-API | Missing '/' in HostNIC labels link
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ovirt-4.0.0-rc
: 4.0.0
Assignee: Juan Hernández
QA Contact: Meni Yakove
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-22 13:09 UTC by Meni Yakove
Modified: 2016-07-05 07:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 07:42:49 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.0+
rule-engine: blocker+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 58252 0 master MERGED restapi: Generate correctly V3 network label links 2016-05-30 15:22:43 UTC
oVirt gerrit 58283 0 ovirt-engine-4.0 MERGED restapi: Generate correctly V3 network label links 2016-05-30 19:18:32 UTC
oVirt gerrit 58540 0 ovirt-engine-4.0 MERGED restapi: Replace "networklabels" with "labels" in V3 2016-06-03 06:42:19 UTC
oVirt gerrit 58595 0 ovirt-engine-4.0 MERGED restapi: Replace "networklabels" with "labels" in V3 2016-06-03 08:26:06 UTC

Description Meni Yakove 2016-05-22 13:09:10 UTC
Description of problem:
HostNIC labels link in REST is missing '/' before label word
/ovirt-engine/api/hosts/d502ece0-4442-4746-b847-1bfd61427d84/nics/2e28bfff-c03c-43fd-9cc2-45b887ab8893labels"

should be /ovirt-engine/api/hosts/d502ece0-4442-4746-b847-1bfd61427d84/nics/2e28bfff-c03c-43fd-9cc2-45b887ab8893/labels"

Version-Release number of selected component (if applicable):
ovirt-engine-4.0.0-0.0.master.20160521171336.git2e1899b.el7.centos.noarch

Comment 1 Red Hat Bugzilla Rules Engine 2016-05-23 06:11:44 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Yaniv Lavi 2016-05-23 13:14:26 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 3 Ori Liel 2016-05-25 14:13:35 UTC
Just to make sure, you request: 

  GET .../api/hosts/xxx/nics/

and in the received NIC the link to the Labels sub-collection is malformed, is that correct? 

Looks like the bug is somewhere in here: 

  AbstractBaseHostNicLabelsResource.addLinks()

Comment 4 Meni Yakove 2016-05-27 13:18:43 UTC
yes, missing '/' before the word 'labels'

Comment 5 Dan Kenigsberg 2016-05-29 09:12:47 UTC
Meni, can you state the REST url that presents this bug?

Comment 6 Meni Yakove 2016-05-29 14:29:28 UTC
What do you mean? Just go to /ovirt-engine/api/hosts/<host_id>/nics/<nic_id> and check the label href on clean engine install

Comment 7 Juan Hernández 2016-05-30 10:07:38 UTC
This regression was introduced by the change that renamed "Label" to "NetworkLabel", in order to introduce the new "AffinityLabel" concept. I'm moving to the infra team.

Comment 8 Meni Yakove 2016-06-01 18:08:24 UTC
In the latest nightly I have '/' before labels but when I go to:
network-ge-1.scl.lab.tlv.redhat.com/ovirt-engine/api/hosts/<host_id>/nics/<nic_id>/labels the label href is:
/ovirt-engine/api/hosts/<host_id>/nics/<nic_id>/networklabels/lb1"

In the href 'networklabels' should be 'labels'

Comment 9 Meni Yakove 2016-06-03 15:32:04 UTC
Juan, did you saw my last comment?

Comment 10 Juan Hernández 2016-06-03 15:34:07 UTC
Yes Meni, patch 58595 should address that issue.

Comment 11 Meni Yakove 2016-06-22 15:09:10 UTC
rhevm-4.0.0.5-0.1.el7ev.noarch

Comment 12 Sandro Bonazzola 2016-07-05 07:42:49 UTC
oVirt 4.0.0 has been released, closing current release.


Note You need to log in before you can comment on or make changes to this bug.