Bug 1338548 - [ceph-ansible] : ISO installation fails as it's looking for Directory 'Installer' which is not present
Summary: [ceph-ansible] : ISO installation fails as it's looking for Directory 'Instal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-22 17:07 UTC by Rachana Patel
Modified: 2016-08-23 19:51 UTC (History)
6 users (show)

Fixed In Version: ceph-ansible-1.0.5-16.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:51:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Rachana Patel 2016-05-22 17:07:53 UTC
Description of problem:
=======================
Ceph Installation using ISO on RHEL cluster fails in Task 'install distro or red hat storage ceph mon' as it's looking for Installer directory which is not present

Version-Release number of selected component (if applicable):
=============================================================
ceph-ansible-1.0.5-15.el7scon.noarch
ceph - 10.2.1-6.el7cp.x86_64

How reproducible:
=================
always


Steps to Reproduce:
===================
1. perform prerequisite on all nodes
2. modify inventory file as below
[mons]
magna067

[osds]
magna067
magna074
magna084

[mdss]
magna100

3. copy iso on installer node and run below command from installer node

4.[root@magna051 ceph-ansible]#  ansible-playbook site.yml -vv -i  /etc/ansible/hosts  --extra-vars '{"ceph_stable": true, "ceph_stable_rh_storage": true, "monitor_interface": "eno1", "ceph_stable_rh_storage_iso_install": true,"ceph_stable_rh_storage_iso_path": "/root/iso/Ceph-2-RHEL-7-20160520.t.0-x86_64-dvd.iso", "journal_collocation": true, "devices": ["/dev/sdb", "/dev/sdc"], "journal_size": 100, "public_network": "10.8.128.0/21", "cephx": true,

Actual results:
================
TASK: [ceph.ceph-common | install distro or red hat storage ceph mon] ********* 
<magna067> REMOTE_MODULE yum name=ceph-mon state=present
failed: [magna067] => {"failed": true}
msg: Error from repoquery: ['/usr/bin/repoquery', '--show-duplicates', '--plugins', '--quiet', '-q', '--disablerepo', '', '--enablerepo', '', '--qf', '%{name}-%{version}-%{release}.%{arch}', 'ceph-mon']: failure: repodata/repomd.xml from rh_storage_installer: [Errno 256] No more mirrors to try.
file:///tmp/rh-storage-repo/Installer/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /tmp/rh-storage-repo/Installer/repodata/repomd.xml"
Could not match packages: failure: repodata/repomd.xml from rh_storage_installer: [Errno 256] No more mirrors to try.
file:///tmp/rh-storage-repo/Installer/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /tmp/rh-storage-repo/Installer/repodata/repomd.xml"


FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/site.retry

magna067                   : ok=29   changed=2    unreachable=0    failed=1   





Additional info:
================

cluster node:-
[root@magna067 ubuntu]# ls -l /tmp/rh-storage-repo/
total 56
-r--r--r--. 1 root root  8774 May 21 02:42 EULA
-r--r--r--. 1 root root 18092 May 21 02:42 GPL
dr-xr-xr-x. 3 root root  4096 May 21 02:42 MON
dr-xr-xr-x. 3 root root  4096 May 21 02:42 OSD
-r--r--r--. 1 root root   165 May 21 02:42 README
-r--r--r--. 1 root root  3211 May 21 02:42 RPM-GPG-KEY-redhat-release
dr-xr-xr-x. 3 root root  4096 May 21 02:42 Tools
-r--r--r--. 1 root root  1976 May 21 02:42 TRANS.TBL

Comment 3 Alfredo Deza 2016-05-23 13:11:52 UTC
Upstream pull request opened https://github.com/ceph/ceph-ansible/pull/806

Comment 7 Rachana Patel 2016-07-27 01:54:48 UTC
verified with ceph-ansible-1.0.5-31.el7scon.noarch, 10.2.2-29.el7cp.x86_64

working as expected hence moving to verified

Comment 9 errata-xmlrpc 2016-08-23 19:51:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.