Bug 133856 - Anaconda crash, 100% reproducable
Summary: Anaconda crash, 100% reproducable
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Target FC4Target
TreeView+ depends on / blocked
 
Reported: 2004-09-27 21:55 UTC by Alan Cox
Modified: 2015-01-04 22:10 UTC (History)
2 users (show)

Fixed In Version: FC3 errata
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 09:29:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-09-27 21:55:09 UTC
Large Athlon64 box, the installer faults at RIP 0x46e480, with or
without ACPI, and whether or not DNS lookups work.

NFS install always crashing just after the IP adderess is obtained and
the lookup of the hostname completes.

Box appears to happily be running installed FC2.

Alan

Comment 1 Jeremy Katz 2004-09-28 01:42:27 UTC
Can you get further for any other install type?  What are the last
messages on tty3/tty4?  

And please define "large athlon64 box" as that's not very descriptive
of the hardware.

Comment 2 Alan Cox 2004-09-28 16:35:41 UTC
I've stripped the box down and get the same problem, so its now 

AMD Athlon64
ABIT KV8Pro Motherboard
Radeon 9000Pro using analog output
Onboard VIA velocity Gigabit ethernet
One IDE DVD-ROM
One IDE Hard disk
Mobility electronics split bridge card
USB Webcam

I'll take the last two off for the next test, I forgot them last time.

Not tried other install types yet.


Comment 3 Alan Cox 2004-09-28 17:20:50 UTC
Ok it seems to be the Webcam. If I remove the webcam then it works.

USB legacy is off so it doesn't look like SMM bugs. It blows up
reliably with the camera present at the address reported and just
after "Reverse domain name lookup failed". With it removed it gets
further. Its currently updating packages


Comment 4 Alan Cox 2004-09-28 18:31:14 UTC
Ok without the camera it all works, and finished an update.  The
camera is a creative camera using the vision chip


Comment 5 Jeremy Katz 2004-09-28 21:05:00 UTC
Post-install, if you plug the camera in, does it crash if you run
kudzu -p -b USB?

Comment 6 Alan Cox 2004-09-28 21:30:05 UTC
It doesnt


Comment 7 Alan Cox 2004-11-04 12:33:51 UTC
Ok this is the webcam, its a lock/recursion between the kernel and
user space when loading the driver, and fixed in the current -ac kernel


Comment 8 Dave Jones 2005-07-15 18:51:01 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 9 Alan Cox 2005-09-08 09:29:05 UTC
Fixed in errata kernels.



Note You need to log in before you can comment on or make changes to this bug.