Bug 1338733 - __inode_ctx_put: fix mem leak on failure
Summary: __inode_ctx_put: fix mem leak on failure
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: unclassified
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1376665
TreeView+ depends on / blocked
 
Reported: 2016-05-23 11:01 UTC by Prasanna Kumar Kalever
Modified: 2017-03-27 18:21 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1376665 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:21:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-05-23 11:01:44 UTC
Description of problem:
up on failure case __inode_ctx_put need to free the allocated memory                      
                                                                                               
Indirect leak of 104 byte(s) in 1 object(s) allocated from:                            
#0 0x496669 in __interceptor_calloc (/usr/local/sbin/glusterfsd+0x496669)                                           
#1 0x7f8a288522f9 in __gf_calloc libglusterfs/src/mem-pool.c:117                                        
#2 0x7f8a17235962 in __posix_acl_ctx_get xlators/system/posix-acl/src/posix-acl.c:308

Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-05-23 11:04:44 UTC
REVIEW: http://review.gluster.org/14504 (loc_wipe: fix to clean missing member) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Vijay Bellur 2016-05-23 11:08:25 UTC
REVIEW: http://review.gluster.org/14505 (__inode_ctx_put: fix mem leak on failure) posted (#1) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 3 Vijay Bellur 2016-06-01 06:16:42 UTC
REVIEW: http://review.gluster.org/14505 (__inode_ctx_put: fix mem leak on failure) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 4 Vijay Bellur 2016-06-01 13:28:54 UTC
COMMIT: http://review.gluster.org/14505 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit a04eaf366779a0632e5b9cdd6d63de0eb62f7449
Author: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
Date:   Mon May 23 14:31:51 2016 +0530

    __inode_ctx_put: fix mem leak on failure
    
    up on failure case __inode_ctx_put need to free the allocated memory
    
    Indirect leak of 104 byte(s) in 1 object(s) allocated from:
        #0 0x496669 in __interceptor_calloc (/usr/local/sbin/glusterfsd+0x496669)
        #1 0x7f8a288522f9 in __gf_calloc libglusterfs/src/mem-pool.c:117
        #2 0x7f8a17235962 in __posix_acl_ctx_get xlators/system/posix-acl/src/posix-acl.c:308
    
    Change-Id: I0ce6da3967c55931a70f77d8551ccf52e4cdfda3
    BUG: 1338733
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Reviewed-on: http://review.gluster.org/14505
    Tested-by: Prasanna Kumar Kalever <pkalever@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 5 Shyamsundar 2017-03-27 18:21:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.