Bug 1338735 - loc_wipe: fix to clean missing member
Summary: loc_wipe: fix to clean missing member
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libglusterfsclient
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 11:03 UTC by Prasanna Kumar Kalever
Modified: 2018-08-29 03:34 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.3 (or later)
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 03:34:51 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Prasanna Kumar Kalever 2016-05-23 11:03:58 UTC
Description of problem:
                                            
                                                                                               
    struct _loc {                                                                             
            const char *path;                                                                  
            const char *name;                                                              
            inode_t    *inode;                                                                                              
            inode_t    *parent;                                                                                 
            uuid_t      gfid;                                                                
            uuid_t      pargfid;
    };

member 'name' is left with out freeing in loc_wipe().

Version-Release number of selected component (if applicable):
mainline

Comment 1 Vijay Bellur 2016-05-23 11:06:27 UTC
REVIEW: http://review.gluster.org/14504 (loc_wipe: fix to clean missing member) posted (#2) for review on master by Prasanna Kumar Kalever (pkalever@redhat.com)

Comment 2 Amar Tumballi 2018-08-29 03:34:51 UTC
This update is done in bulk based on the state of the patch and the time since last activity. If the issue is still seen, please reopen the bug.


Note You need to log in before you can comment on or make changes to this bug.