Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338744 - [RFE] Validate pre-conditions during installation
Summary: [RFE] Validate pre-conditions during installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: RFEs
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.1.0-beta
: 4.1
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
: 1370433 1380142 (view as bug list)
Depends On:
Blocks: ovirt-node-ng
TreeView+ depends on / blocked
 
Reported: 2016-05-23 11:27 UTC by Fabian Deutsch
Modified: 2017-02-08 21:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:36:18 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
bmcclain: priority_rfe_tracking+
cshao: testing_plan_complete+
mgoldboi: planning_ack+
fdeutsch: devel_ack+
ycui: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1326232 0 high CLOSED [RFE] Validate basic Node status during boot 2021-02-22 00:41:40 UTC
oVirt gerrit 65737 0 None MERGED imgbase: add validation for missing thin pool 2020-07-09 07:47:17 UTC
oVirt gerrit 66005 0 None MERGED imgbased: Add validation for FS 2020-07-09 07:47:16 UTC
oVirt gerrit 67033 0 None MERGED validation: Add boot partition validation 2020-07-09 07:47:16 UTC

Internal Links: 1326232

Description Fabian Deutsch 2016-05-23 11:27:41 UTC
Description of problem:
Currently Node does not complain if it is getting installed in an environment where i.e. the storage layout is wrong (i.e. a thin pool is missing)

This RFE is about checking for the most important bits during installation:
- Available thin pool
- / on thin pool
- /var is a separate volume

Comment 1 Yaniv Kaul 2016-05-25 08:09:09 UTC
If this is going to meet 4.0 GA, it needs an exception/blocker status. Otherwise, please push to 4.1.

Comment 4 Red Hat Bugzilla Rules Engine 2016-09-22 10:18:32 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 5 Red Hat Bugzilla Rules Engine 2016-09-22 10:19:20 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 6 Fabian Deutsch 2016-09-30 10:59:44 UTC
*** Bug 1380142 has been marked as a duplicate of this bug. ***

Comment 7 cshao 2017-01-11 10:36:49 UTC
Test Version:
redhat-virtualization-host-4.1-0.20170104.0
imgbased-0.9.2-0.1.el7ev.noarch

1. no Available thin pool
Test Steps:
1) Install RHVH 4.1 via interactive anaconda.
2) Enter MANUAL PARTITIONING page via choosing "I will configure partitioning" in the INSTALLATION DESTINATION page.
3) Select partitioning scheme as LVM, not LVM Thin Provisioning.
4) Click "Click here to create them automatically".
5) Finish the remained steps and wait to see the error window popping up.

Test Results:
A window is popped up at the end of installation but before reboot. There is an error message at the beginning of the window saying:
[ERROR] LVM Thin Provisioning partitioning scheme is required.
For autoinstall via Kickstart with LVM Thin Provisioning check options: --thinpool and --growPlease consult documentation for details


2. / is not on thin pool
Test Steps:
1) Install RHVH 4.1 via interactive anaconda.
2) Enter MANUAL PARTITIONING page via choosing "I will configure partitioning" in the INSTALLATION DESTINATION page.
3) Select partitioning scheme as LVM Thin Provisioning.
4) Click "Click here to create them automatically".
5) Modify "/" partitioning scheme as LVM. and save.
6) Finish the remained steps and wait to see the error window popping up.

Test Results:
A window is popped up at the end of installation but before reboot. There is an error message at the beginning of the window saying:
[INFO] Trying to create a manageable base from "/"
[ERROR] LVM Thin Provisioning partitioning scheme is required.
For autoinstall via Kickstart with LVM Thin Provisioning check options: --thinpool and --growPlease consult documentation for details


3. /var is not a separate volume
Test Steps:
1) Install RHVH 4.1 via interactive anaconda.
2) Enter MANUAL PARTITIONING page via choosing "I will configure partitioning" in the INSTALLATION DESTINATION page.
3) Delete existing partitions if needed.
4) Select partitioning scheme as LVM Thin Provisioning.
5) Add partitions manually using the "+" icon at the lower left corner. Add /, /boot and swap, don't add /var.
6) Finish the remained steps and wait to see the error window popping up.

Test Results:
A window is popped up at the end of installation but before reboot. There is an error message at the bottom of the window saying:
It's required /var as separate mountpoint!
Please check documentation for more details!

RHVH can handle above scenario correctly.
So the bug is fixed, change bug status to VERIFIED.

Comment 8 Douglas Schilling Landgraf 2017-01-17 20:10:12 UTC
*** Bug 1370433 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.