Bug 1338755 - qemu-kvm-rhev doesn't reload udev rules before triggering for kvm device
Summary: qemu-kvm-rhev doesn't reload udev rules before triggering for kvm device
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: All
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Yiqian Wei
URL:
Whiteboard:
Depends On: 1333159
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 11:51 UTC by Miroslav Rezanina
Modified: 2019-12-16 05:49 UTC (History)
14 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1333159
Environment:
Last Closed: 2016-11-07 21:11:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Comment 1 Miroslav Rezanina 2016-06-15 13:08:29 UTC
Fix included in qemu-kvm-rhev-2.6.0-6.el7

Comment 6 Yanan Fu 2016-09-14 07:20:37 UTC
Test with two version:
unfixed version: qemu-kvm-rhev-2.3.0-31.el7.x86_64
fixed version:   qemu-kvm-rhev-2.6.0-25.el7.x86_64

But,got same result,would you please help check the steps?
Anything wrong, please correct it, thanks.

Test steps:
1. unload kvm module, uninstall qemu-kvm-rhev
  # rmmod kvm-intel kvm
  # rpm -qa | grep qemu-kvm-rhev
    qemu-kvm-rhev-2.3.0-31.el7.x86_64
  # yum remove qemu-kvm-rhev-2.3.0-31.el7.x86_64

2. load kvm module
 # modprobe kvm_intel
 # lsmod | grep kvm
   kvm_intel             170125  0 
   kvm                   543643  1 kvm_intel
   irqbypass              13503  2 kvm,vfio_pci
3. check owner of /dev/kvm, it is "root.root" 
 # ll /dev/kvm 
  crw-------. 1 root root 10, 232 Sep 14 02:28 /dev/kvm

4. Install qemu-kvm-rhev
  # yum install -y qemu-kvm-rhev
  # rpm -qa | grep qemu-kvm-rhev
    qemu-kvm-rhev-2.3.0-31.el7.x86_64

5. check owner of /dev/kvm
  # ll /dev/kvm 
   crw-rw-rw-. 1 root kvm 10, 232 Sep 14 02:30 /dev/kvm

This is for unfixed version(qemu-kvm-rhev-2.3.0-31.el7.x86_64), after qemu-kvm-rhev be installed, the owner of /dev/kvm change to root.kvm automatically.
For fixed version, the result is same with above.

Comment 7 Yanan Fu 2016-09-14 08:21:28 UTC
cancel needinfo of comment6.

-------------------------reproduce---------------------
Test version:
qemu-kvm-rhev-2.3.0-31.el7.x86_64

Test steps:
1. unload kvm module, uninstall qemu-kvm-rhev
  # rmmod kvm-intel kvm
  # rpm -qa | grep qemu-kvm-rhev
    qemu-kvm-rhev-2.3.0-31.el7.x86_64
  # yum remove -y qemu-kvm-rhev-2.3.0-31.el7.x86_64

2. load kvm module
  # modprobe kvm_intel
  # lsmod | grep kvm
   kvm_intel             170125  0 
   kvm                   543643  1 kvm_intel
   irqbypass              13503  2 kvm,vfio_pci

3. check owner of /dev/kvm, it is "root.root", right result.
  # ll /dev/kvm
   crw-------. 1 root root 10, 232 Sep 14 03:44 /dev/kvm

4. Install qemu-kvm-rhev while doing "udevadm trigger"
  # udevadm trigger; yum install -y ./qemu-*
  # rpm -qa | grep qemu-kvm-rhev
    qemu-kvm-rhev-2.3.0-31.el7.x86_64

5. check owner of /dev/kvm, it is "root.root", so hit this issue.
  # ll /dev/kvm
   crw-------. 1 root root 10, 232 Sep 14 03:45 /dev/kvm

6. uninstall qemu-kvm-rhev, then install qemu-kvm-rhev without "udevadm trigger"
  # yum remove -y qemu-kvm-rhev-2.3.0-31.el7.x86_64
  # yum install -y ./qemu-*

7. check owner of /dev/kvm, it is "root.kvm"
  # ll /dev/kvm
   crw-rw-rw-. 1 root kvm 10, 232 Sep 14 03:52 /dev/kvm

reproduce this bug successfully according the result of step 5.


-------------------------verification---------------------
Test version:
qemu-kvm-rhev-2.6.0-25.el7.x86_64

Test steps:
same with above.
1. unload kvm module, uninstall qemu-kvm-rhev
2. load kvm module
3. check owner of /dev/kvm, it is "root.root", right result.
  # ll /dev/kvm
   crw-------. 1 root root 10, 232 Sep 14 04:17 /dev/kvm

4. Install qemu-kvm-rhev while doing "udevadm trigger"
  # udevadm trigger; yum install -y ./qemu-*
   (qemu-kvm-rhev-2.6.0-25.el7.x86_64)
5. check owner of /dev/kvm, it is "root.kvm".
  # ll /dev/kvm
   crw-rw-rw-. 1 root kvm 10, 232 Sep 14 04:17 /dev/kvm

Move to VERIFIED according to the test result above.

Comment 9 errata-xmlrpc 2016-11-07 21:11:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.