Bug 1338761 - GOA complains, credential need to be re-entered, but no changed behaviour afterwards
Summary: GOA complains, credential need to be re-entered, but no changed behaviour aft...
Keywords:
Status: CLOSED DUPLICATE of bug 1340203
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 24
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 12:08 UTC by lennart_reuther
Modified: 2018-09-09 22:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-28 13:13:16 UTC


Attachments (Terms of Use)

Description lennart_reuther 2016-05-23 12:08:50 UTC
Description of problem:

None of the GOA services (2 x google account, 1 x owncloud) can be used. The GOA UI asks for re-entering the credentials for each service - which is successfull but does actually not change the message or any functionality.

journal-ctl returns the following message:

org.gnome.OnlineAccounts[1257]: (goa-daemon:1482): GoaBackend-WARNING **: secret_password_lookup_sync() failed: The name :1.9 was not provided by any .service files



How reproducible: unknown

Actual results:
Can't use accounts handled by GOA.

Expected results:
Can use accounts handled by GOA.


Additional info:

It is an updated Fedora (from 23 to 24 beta), done by DNF.

As a former bug (Bug 895067) asked whether the firewall is running, 
"systemctl status firewalld.service" returns 

firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: active (running) since Mo 2016-05-23 08:31:38 IST; 4h 25min ago
 Main PID: 917 (firewalld)
    Tasks: 2 (limit: 512)
   CGroup: /system.slice/firewalld.service
           └─917 /usr/bin/python3 -Es /usr/sbin/firewalld --nofork --nopid

Mai 23 08:31:38 cs-nightlife-local systemd[1]: Starting firewalld - dynamic firewall daemon...
Mai 23 08:31:38 cs-nightlife-local systemd[1]: Started firewalld - dynamic firewall daemon.
Mai 23 08:31:39 cs-nightlife-local /firewalld[917]: WARNING: FedoraServer: INVALID_SERVICE: cockpit

Comment 1 leo hermans 2016-07-01 20:40:53 UTC
I faced the same problem, but starting today I could enter the Google Online Accounts and use them without problem.
Maybe there is a relation with the new Kernel~4.6.3-300.fc24.x86_64 I installed early today.

Comment 2 Persona non grata 2016-07-25 23:31:32 UTC
Greetings,

I am facing the same crippling bug. I am unable to use Evolution, GNOME Calender or GNOME contacts due to this bug.

The name and version of the buggy software
Name        : gnome-online-accounts
Version     : 3.20.2

Description of problem:
Attempting to add a Google account "appears" to succeed then throws the error "Credentials have expired". I have tried removing the accounts as well as the credentials in Seahorse to no avail.

Operating System:
Fedora 24 x86

Relevant information from journalctl:

org.gnome.OnlineAccounts[2382]: ** Message: Remote error from secret service: org.freedesktop.Secret.Error.NoSess
ion: The session wrapping the secret does not exist
org.gnome.OnlineAccounts[2382]: (goa-daemon:2526): GoaBackend-WARNING **: secret_password_store_sync() failed: Th
e session wrapping the secret does not exist
org.gnome.OnlineAccounts[2382]: ** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.11 was not provided by any .service files
org.gnome.OnlineAccounts[2382]: (goa-daemon:2526): GoaBackend-WARNING **: secret_password_lookup_sync() failed: The name :1.11 was not provided by any .service files
org.gnome.OnlineAccounts[2382]: goa-daemon-Message: /org/gnome/OnlineAccounts/Accounts/account_1469488882_3: Setting AttentionNeeded to TRUE because EnsureCredentials() failed with: Failed to retrieve credentials from the keyring (goa-error-quark, 4)

Comment 3 Persona non grata 2016-07-26 00:00:07 UTC
After further testing I believe I have found the method to reproduce this bug.

Step 1. Add an account to gnome-online-accounts
Step 2. Log out
Step 3. Log in
Step 4. Launch gnome-online-accounts, the "Credentials have expired" is thrown.

A Seahorse prompt is shown immediately after logging in after reboot or cold boot to unlock the keychain. Upon successfully entering the keychain password everything works as expected. Logging in and out of GDM does not trigger the Seahorse prompt which throws this error. Manually unlocking Seahorse does not resolve the error either.

Comment 4 Debarshi Ray 2016-07-26 14:05:39 UTC
(In reply to comment #3)
> After further testing I believe I have found the method to reproduce this
> bug.
> 
> Step 1. Add an account to gnome-online-accounts
> Step 2. Log out
> Step 3. Log in
> Step 4. Launch gnome-online-accounts, the "Credentials have expired" is
> thrown.

Sounds like a systemd/dbus problem. Fedora 24 now uses a systemd --user to spawn dbus-daemon. Unfortunately it doesn't clean up the dbus services when the user logs out, which creates this problem.

Does the problem go away if you reboot instead of log out/in?

Comment 5 Debarshi Ray 2016-07-26 14:15:56 UTC
(In reply to Debarshi Ray from comment #4)
> (In reply to comment #3)
> > After further testing I believe I have found the method to reproduce this
> > bug.
> > 
> > Step 1. Add an account to gnome-online-accounts
> > Step 2. Log out
> > Step 3. Log in
> > Step 4. Launch gnome-online-accounts, the "Credentials have expired" is
> > thrown.
> 
> Sounds like a systemd/dbus problem. Fedora 24 now uses a systemd --user to
> spawn dbus-daemon. Unfortunately it doesn't clean up the dbus services when
> the user logs out, which creates this problem.
> 
> Does the problem go away if you reboot instead of log out/in?

If it does, then it is a duplicate of bug 1340203

Comment 6 lennart_reuther 2016-07-26 17:46:40 UTC
Hi Debarshi, 

yes after a restart it works again like expected. 

In my case the gnome-online-account might after the re-login not instantly complain about all accounts expired, but after the first trials of using those (e.g. checking mail with evolution). Yes, the duplicate bug 1340203 looks fitting.

Cheers, Lennart

Comment 7 Persona non grata 2016-07-26 18:34:43 UTC
(In reply to Debarshi Ray from comment #4)
> (In reply to comment #3)
> > After further testing I believe I have found the method to reproduce this
> > bug.
> > 
> > Step 1. Add an account to gnome-online-accounts
> > Step 2. Log out
> > Step 3. Log in
> > Step 4. Launch gnome-online-accounts, the "Credentials have expired" is
> > thrown.
> 
> Sounds like a systemd/dbus problem. Fedora 24 now uses a systemd --user to
> spawn dbus-daemon. Unfortunately it doesn't clean up the dbus services when
> the user logs out, which creates this problem.
> 
> Does the problem go away if you reboot instead of log out/in?

Yes, the problem goes away after rebooting. Feel free to merge my prior comments with Bug 1340203 if you feel it is appropriate to do so.

Thanks!

Comment 8 Debarshi Ray 2016-07-28 13:13:16 UTC

*** This bug has been marked as a duplicate of bug 1340203 ***


Note You need to log in before you can comment on or make changes to this bug.