Bug 1338782 - Exception when querying Modeshape VDB
Summary: Exception when querying Modeshape VDB
Keywords:
Status: CLOSED DUPLICATE of bug 1332859
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: ModeShape, Integration
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Horia Chiorean
QA Contact: Filip Elias
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 12:21 UTC by Filip Elias
Modified: 2016-05-23 12:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
DV 6.3 ER3
Last Closed: 2016-05-23 12:37:44 UTC
Type: Bug


Attachments (Terms of Use)
Exception (13.11 KB, text/plain)
2016-05-23 12:21 UTC, Filip Elias
no flags Details

Description Filip Elias 2016-05-23 12:21:15 UTC
Created attachment 1160576 [details]
Exception

Description of problem:

When ModeShape vdb is queried through jdbc, server will through an exception. 
The whole exception is in the attachment. This issue is probably caused by bz1332859.

Connector worker process failed for atomic-request=adU4HvHdO/aA.0.1.0: org.teiid.translator.jdbc.JDBCExecutionException: 0 TEIID11008:TEIID11004 Error executing statement(s): [SQL: SELECT g_0."jcr:name", g_0."jcr:path", g_0."jcr:primaryType", g_0."jcr:score", g_0."jcr:uuid", g_0."mmcore:description", g_0."mmcore:maxSetSize", g_0."mmcore:modelType", g_0."mmcore:nameInSource", g_0."mmcore:originalFile", g_0."mmcore:primaryMetamodelUri", g_0."mmcore:producerName", g_0."mmcore:producerVersion", g_0."mmcore:supportsDistinct", g_0."mmcore:supportsJoin", g_0."mmcore:supportsOrderBy", g_0."mmcore:supportsOuterJoin", g_0."mmcore:supportsWhereAll", g_0."mmcore:visible", g_0."mode:depth", g_0."mode:localName", g_0."mode:sha1", g_0."vdb:builtIn", g_0."vdb:checksum", g_0."vdb:description", g_0."vdb:pathInVdb", g_0."vdb:sourceJndiName", g_0."vdb:sourceName", g_0."vdb:sourceTranslator", g_0."vdb:visible", g_0."xmi:uuid", g_0."xmi:version" FROM "vdb:model" AS g_0]
	at org.teiid.translator.jdbc.JDBCQueryExecution.execute(JDBCQueryExecution.java:131) [translator-jdbc-8.12.5.redhat-4.jar:8.12.5.redhat-4]
	at org.teiid.dqp.internal.datamgr.ConnectorWorkItem.execute(ConnectorWorkItem.java:364)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.8.0_45]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) [rt.jar:1.8.0_45]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.8.0_45]
	at java.lang.reflect.Method.invoke(Method.java:497) [rt.jar:1.8.0_45]
	at org.teiid.dqp.internal.datamgr.ConnectorManager$1.invoke(ConnectorManager.java:211)
	at com.sun.proxy.$Proxy131.execute(Unknown Source)
	at org.teiid.dqp.internal.process.DataTierTupleSource.getResults(DataTierTupleSource.java:306)
	at org.teiid.dqp.internal.process.DataTierTupleSource$1.call(DataTierTupleSource.java:112)
	at org.teiid.dqp.internal.process.DataTierTupleSource$1.call(DataTierTupleSource.java:108)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_45]
	at org.teiid.dqp.internal.process.FutureWork.run(FutureWork.java:65)
	at org.teiid.dqp.internal.process.DQPWorkContext.runInContext(DQPWorkContext.java:276)
	at org.teiid.dqp.internal.process.ThreadReuseExecutor$RunnableWrapper.run(ThreadReuseExecutor.java:119)
	at org.teiid.dqp.internal.process.ThreadReuseExecutor$3.run(ThreadReuseExecutor.java:210)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_45]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_45]
	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_45]
Caused by: java.sql.SQLException: Table 'vdb:model' does not exist.
Table 'g_0' does not exist.

Comment 1 Van Halbert 2016-05-23 12:35:49 UTC
Correct, it is caused by the wrong module name.  And that BZ has been fixed in ER4.

Comment 2 Van Halbert 2016-05-23 12:37:44 UTC

*** This bug has been marked as a duplicate of bug 1332859 ***


Note You need to log in before you can comment on or make changes to this bug.