Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338944 - "enter" key is not working when searching on topology
Summary: "enter" key is not working when searching on topology
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Einat Pacifici
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-23 16:59 UTC by Dafna Ron
Modified: 2018-01-05 23:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Dafna Ron 2016-05-23 16:59:32 UTC
Description of problem:

when you type something in the topology search bar and than press "enter" nothing happens. 

Version-Release number of selected component (if applicable):

cfme-5.6.0.7-beta2.6.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. navigate to compute -> containers -> topology
2. in the search bar type the name of one of the objects
3. press "enter" 

Actual results:

nothing happens

Expected results:

we should be able to search using the enter key

Additional info:

Comment 1 Federico Simoncelli 2016-05-23 17:35:22 UTC
I believe this happens cross-provider. Assigning to Alissa for the time being.

Comment 2 Alissa 2016-05-24 08:20:25 UTC
this issue is a duplicate of upstream 
https://github.com/ManageIQ/manageiq/issues/8035

afaik this is how it's supposed to work per patternfly specification.

Serena, the lack of responding to "enter" key - this is how it's supposed to work per pf specification, no? https://www.patternfly.org/wikis/search/#basicsearch

Comment 3 Federico Simoncelli 2016-06-01 08:28:49 UTC
Dave this is not container specific, in case you think otherwise (as you changed the whiteboard) can you please argument? Thanks.

Comment 4 Serena 2016-08-08 13:20:52 UTC
Alissa, I would think that this should work more like the Find specification here: http://www.patternfly.org/pattern-library/forms-and-controls/find/#_design

Comment 5 Chris Pelland 2017-08-21 13:08:24 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 6 Chris Pelland 2017-08-21 13:10:27 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.