Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1338952 - image based provisioning through SSH fails with any compute resource if foreman_openscap is installed
Summary: image based provisioning through SSH fails with any compute resource if forem...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Marek Hulan
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1406795
TreeView+ depends on / blocked
 
Reported: 2016-05-23 17:23 UTC by Kedar Bidarkar
Modified: 2019-09-26 14:37 UTC (History)
3 users (show)

Fixed In Version: rubygem-foreman_openscap-0.5.3.11-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1406795 (view as bug list)
Environment:
Last Closed: 2016-07-27 11:25:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15157 0 Normal Closed image based provisioning through SSH fails with any compute resource if foreman_openscap is installed 2020-11-16 12:51:22 UTC

Description Kedar Bidarkar 2016-05-23 17:23:10 UTC
Description of problem:
image based provisioning fails with vmware compute resource

Version-Release number of selected component (if applicable):
sat62-snap12.1

How reproducible:


Steps to Reproduce:
1. Create a vmware compute resource
2.Add an image to the above created vmware compute resource
3. provisiong a new host with the above compute resource and image

Actual results:
Provisioning of the "New host" fails to get configured as per the Finish template. But the host could be accessible.

Expected results:
Provisioning of the "New host" should be successful and should get configured as per the Finish template.

Additional info:
a) The "new host" is accessible due to the fact that the ifcfg-<dev> files is configured for dhcp 
b) Rendering of the Finish template works fine.

Comment 2 Marek Hulan 2016-05-24 10:21:48 UTC
After deugging it turned out it's caused by foreman_openscap plugin which registers AR callback to do a puppetrun which fails (it does not even check that it's allowed in settings). Failure itself is harmless but it registers message in host.errors causing SSH orchestration fail later without any sane message or log.

Comment 3 Marek Hulan 2016-05-24 10:22:18 UTC
Created redmine issue http://projects.theforeman.org/issues/15157 from this bug

Comment 4 Bryan Kearney 2016-05-24 12:17:51 UTC
Upstream bug assigned to mhulan@redhat.com

Comment 5 Bryan Kearney 2016-05-24 12:17:53 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15157 has been closed

Comment 6 Kedar Bidarkar 2016-06-02 17:08:34 UTC
Image based Provisioning now works fine through SSH. ( Tested with RHEVM )

VERIFIED With sat62-snap(GA)-14.0

Comment 7 Bryan Kearney 2016-07-27 11:25:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.