Bug 133897 - Hotplu doesn't get run when usb devices are added on computers with ASUS P8P mainboard
Hotplu doesn't get run when usb devices are added on computers with ASUS P8P ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 07:06 EDT by David Jansen
Modified: 2015-01-04 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2004-09-28 07:06:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I noticed on some computers that adding a usb device doesn't activate
hotplug, so the device doesn't become available (nothing in logs, no
entries in /proc/bus/usb or /sys/bus/usb).
Since it works on other machines with the same setup (installed using
the same kickstart file), I think it is an issue with the hardware,
probably the mainboard, which is an ASUS P8P (or P8P800SE) in all the
cases where I encountered this bug.

Version-Release number of selected component (if applicable):
hotplug-2004_04_01-1 kudzu-1.1.68.2-1 kernel-2.6.7-1.494.2.2 or
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. boot machine in kernel 2.6.7-1.492.2.2 or 2.6.8-1.521
2. plug in a usb device (tried with disk, camera, mouse)

    

Actual Results:  nothing happens (no device available, nothing in
logs, no entries in /proc/bus/usb or /sys/bus/usb)

Expected Results:  device should have been detected by hotplug and
made available to the system.


Additional info:

One of these machines still had kernel 2.6.6-1.435 installed, and
there it works.

Bug is the same with SMP kernels of those same releases.

There is one way to make such devices work: if it is plugged in when
the system is booted. So the usb mouse will usuallly work, only when
the mouse gets unplugged by accident, this requires a reboot.
No such workaround for flash keys, usb disks, cameras and probably
other usb devices.
Comment 1 Bill Nottingham 2004-09-28 12:31:17 EDT
If it's not getting any messages at all, that's a kernel/driver bug.
Comment 2 David Jansen 2004-10-08 10:14:21 EDT
Additional info: when I disable USB 2 in the BIOS on one of those
machines, the kernel does see new devices when they are plugged in. So
for USB 1 devices, this is a workaround, and maybe it gives the kernel
develloppers a clue about the location of this bug.
Comment 3 David Jansen 2004-11-16 11:16:03 EST
FC3 works fine on these machines, with USB 2 enabled in the BIOS.
I'll try the 2.6.9 kernel from updates-testing on FC2 tomorrow to see
if it solved the problem there also.
Comment 4 Dave Jones 2005-04-16 01:43:47 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.