Bug 1339 - raidtools fail in RHL Beta 5.8.1.1
raidtools fail in RHL Beta 5.8.1.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: raidtools (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-25 15:44 EST by ctm
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-01 15:32:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ctm 1999-02-25 15:44:17 EST
raidutils seems to be half-baked.  Our raid0 didn't come
up.  Looking
in /etc/rc.d/rc.sysinit it's clear that they look for
whether or not
/sbin/raidadd is executable, but raidadd is no longer
included in the
raidtools.  I thought that changing raidadd to raidstart
would fix
things, but it didn't.  I need to investigate more.

The man page for raidstart lists raidstart twice under a
heading of
"Avaible commands" (Availible is misspelled).

The documentation for raidtools refers to the old "md"-named
apps

I poked around in the documentation and the source code and
still wasn't able to get our raid0 running, even though it
was running fine before upgrading from Red Hat 5.2 to beta
5.8.1.1.
Comment 1 ajayr 1999-04-01 19:25:59 EST
you have added raidtools-0.90 which needs a kernel patch for 2.2.x
forn ftp.kernel.org/pub/daemons/raid/alpha/raid0145... but when I
include this patch to my kernel spec it breaks because of the DAC960
patches. I have moved back to raid-0.50beta which works for me.
Comment 2 Jay Freeman 1999-05-05 18:57:59 EDT
I have noticed that this has been assigned for a long time, wanted to
get some juices flowing again...  Recently the RAID people released a
new version of the patch which is much easier to get cleanly applied
onto the more current kernels (since 2.2.4 made some major
modifications to some of the functions involved).  This patch is for
2.2.6 however, but might go well onto 2.2.5 (it should work better
than the 2.2.3 patch anyway).  On 2.2.7 there is only one reject
which is really easy to fix in case there are any plans on upgrading
the kernel packages any time soon... hint, hint... wink, wink... :)
Comment 3 Erik Troan 1999-06-01 15:32:59 EDT
fixed before 6.0

Note You need to log in before you can comment on or make changes to this bug.