Bug 133902 - Installer insists on a mouse when using display=remote:0
Summary: Installer insists on a mouse when using display=remote:0
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 12:39 UTC by Matthew Booth
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 17:50:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Booth 2004-09-28 12:39:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040909

Description of problem:
When installing using a remote display, the installer will probe the
local graphics card and mouse. If you don't have a mouse, it will
prompt you to specify a mouse manually or use text only mode. It will
then ignore the selection and correctly open a remote display.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
0. Remove the mouse from the system.
1. Boot from CD 1
2. Type "linux askmethod display=remoteworkstation:0"
3. Follow the prompts to find nfs mounted CD isos.
4. Anaconda starts

Actual Results:  Complains that no mouse was detected and prompts you
to specify one or use text mode.

Expected Results:  Doesn't bother probing X or for a mouse.

Additional info:

Comment 1 Jeremy Katz 2004-09-28 14:10:44 UTC
Changed so we don't prompt for mouse type on remote display.  We still
have to probe so that we have the information later for setting up X
on the installed system.

Comment 2 Jay Turner 2005-01-13 17:50:24 UTC
Closing out.  Please reopen if the problem is still present in recent code.


Note You need to log in before you can comment on or make changes to this bug.