Bug 133903 - PAM and userhelper not working for ethereal
PAM and userhelper not working for ethereal
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 09:01 EDT by Rui Carmo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 02:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rui Carmo 2004-09-28 09:01:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
On an stock installation of FC2 (updates only, no extra packages or
foreign RPMs), launching ethereal does not invoke PAM or userhelper to
raise privilege levels, i.e., non-root users cannot start Ethereal
from menus or launchers and perform packet traces.

The workaround is to start a terminal window and use su or sudo, but
it would be preferrable for novices to be prompted for the root
password correctly (same as, say, hwbrowser and other system tools).

Relevant desktop, helper and global PAM entries exist for ethereal,
but there seems to be something amiss.

Version-Release number of selected component (if applicable):
ethereal-gnome-0.10.5-0.2.2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2
2. yum or RHN it to latest packages, add ethereal, ethereal-gnome
3. Log in as an unprivileged user and start Ethereal from the menu. It
launches immediatly, but you cannot perform traces nor are you asked
for the root password to do so.
    

Actual Results:  I could not perform packet traces without launching
Ethereal from a terminal window using the root account.

Expected Results:  I should have been prompted for the root password
either upon launching Ethereal or upon starting a packet trace.

Additional info:
Comment 1 Radek Vokal 2004-10-05 15:43:06 EDT
This is really strange behaviour as I have experienced the same bug on
one of my PC's but the others are working just fine. Can you send me
the usermode version you're using. 

$ rpm -q usermode
usermode-1.73-1

You're correct that pam.d and console.apps files are present and are
same on both machines. 
Comment 3 Radek Vokal 2004-10-06 03:22:00 EDT
Ethereal when is installed localy doesn't use /usr/bin/ethereal but
other file. Check 

$ which ethereal
/usr/bin/ethereal

if you've got something else than you've propably installed other
ethereal localy. 


Note You need to log in before you can comment on or make changes to this bug.