Bug 133907 - anaconda says AS but I'm installing ES
Summary: anaconda says AS but I'm installing ES
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 13:39 UTC by Bernd Bartmann
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:43:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2004-09-28 13:39:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
While installing RHES4 Beta1 ES I noticed that anaconda everywhere
says AS instead of ES. Also the boot menu entry in grub.conf lists AS.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install RHES4 Beta1 ES and watch out for "AS"
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2004-09-28 14:12:21 UTC
Did the splash screen in anaconda say AS or ES?  How did you install?

Comment 2 Bernd Bartmann 2004-09-28 14:26:52 UTC
I booted from ES-disc1 passing "linux askmethod" to the boot prompt.
Then I did an NFS install. Install language was German.

The help text on left on the first graphical screen shows "Willkommen
zu Red Hat Enterprise Linux AS" and the splash screen shows "redhat
BETA Red Hat Enterprise Linux AS"

Comment 3 Jeremy Katz 2004-09-28 14:44:14 UTC
How did you set up your NFS tree?  Can you provide the md5sum of
RedHat/base/product.img in your nfs tree?

Comment 4 Bernd Bartmann 2004-09-28 14:47:34 UTC
I just created a directory /data/Nahant_Beta1 on my NFS server
containing the ISO images. /data is the NFS exported directory:

[root@picard root]# ls -l /data/Nahant_Beta1/
total 2243376
-rw-rw-r--    1 bart     bart          897 Sep 21 14:44 MD5SUM
-rw-rw-r--    1 bart     bart          292 Sep 22 14:58 MD5SUM.docs
-rw-------    1 bart     bart     69605376 Sep 22 14:58
nahant-beta1-docs.iso
-rw-------    1 bart     bart     158765056 Sep 20 23:27
nahant-i386-AS-disc1.iso
-rw-------    1 bart     bart     647761920 Sep 20 23:24
nahant-i386-disc2.iso
-rw-------    1 bart     bart     666482688 Sep 20 23:25
nahant-i386-disc3.iso
-rw-------    1 bart     bart     593522688 Sep 20 23:26
nahant-i386-disc4.iso
-rw-------    1 bart     bart     158765056 Sep 20 23:27
nahant-i386-ES-disc1.iso
-rw-rw-r--    1 bart     bart         5544 Sep 20 22:34 README-en
-rw-rw-r--    1 bart     bart        18006 Sep 20 22:34 RELEASE-NOTES-en



Comment 5 Bernd Bartmann 2004-09-28 14:49:43 UTC
Here is the requested md5sum of the file in the ISO image:

e880e69e6e56483903701ced8532b1a5  /mnt/dummy/RedHat/base/product.img

Comment 6 Jeremy Katz 2004-09-28 21:30:44 UTC
Are you sure you booted from the ES disc1 and not the AS disc1?  That
md5sum is correct but I can't reproduce what you're seeing here.

Comment 7 Bernd Bartmann 2004-09-29 07:36:47 UTC
Yes I'm sure that I booted from ES disc1. Just a guess: As I also have
the AS disc1 ISO image on my NFS server maybe anaconda mounted this
one instead of ES?

Comment 8 Bernd Bartmann 2004-09-29 07:38:06 UTC
I forgot to mention that after the install the system appears as ES
and /etc/redhat-release also says so.

Comment 9 Jay Turner 2004-09-29 11:05:38 UTC
If you had the AS ISOs in the same directory as the ES ISOs, then yes,
anaconda might have grabbed the wrong one.  Please try to reproduce
with just the ES disc1 in the directory.

Comment 10 Bernd Bartmann 2004-09-29 12:59:36 UTC
Yep, moving AS disc1 out of the directory seems to fix the issue. 

Comment 11 Jeremy Katz 2004-09-29 15:43:01 UTC
This is, unfortunately, expected as the different variants are
supposed to appear as much alike as possible (in fact, the boot media
is identical)


Note You need to log in before you can comment on or make changes to this bug.