Bug 1339096 - [ceph-ansible] RHEL ISO installation fails with "No Package matching 'ceph-mon' found available, installed or updated"
Summary: [ceph-ansible] RHEL ISO installation fails with "No Package matching 'ceph-mo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-24 07:06 UTC by Tejas
Modified: 2016-09-23 16:53 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-1.0.5-18.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:51:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Tejas 2016-05-24 07:06:27 UTC
Description of problem:
ISO installation on RHEL is failing withe the below error:
TASK: [ceph.ceph-common | install distro or red hat storage ceph mon] ********* 
failed: [magna077] => {"changed": false, "failed": true, "rc": 0, "results": []}
msg: No Package matching 'ceph-mon' found available, installed or updated

Version-Release number of selected component (if applicable):
ceph-ansible: 1.0.5-15.el7scon.noarch


How reproducible:
Always

Steps  to Reproduce:
1. Perform the necessay prerequisites on the nodes (firewall settings etc)
2. configure the installer node
3. start the installation

Actual results:
install fails in install of ceph-mon

Expected results:
Install should go through

Additional info:

TASK: [ceph.ceph-common | add ceph stable repository] ************************* 
skipping: [magna077]

TASK: [ceph.ceph-common | add ceph stable repository] ************************* 
skipping: [magna077]

TASK: [ceph.ceph-common | add ceph development repository] ******************** 
skipping: [magna077]

TASK: [ceph.ceph-common | add ceph development repository] ******************** 
skipping: [magna077]

TASK: [ceph.ceph-common | add inktank ceph enterprise repository] ************* 
skipping: [magna077]

TASK: [ceph.ceph-common | add red hat storage repository] ********************* 
skipping: [magna077]

TASK: [ceph.ceph-common | install ceph] *************************************** 
skipping: [magna077]

TASK: [ceph.ceph-common | set_fact ceph_stable_rel_pkg="{{ ceph_stable_releases | union([ 'infernalis' ]) }}"
] *** 
ok: [magna077]

TASK: [ceph.ceph-common | install distro or red hat storage ceph mon] ********* 
failed: [magna077] => {"changed": false, "failed": true, "rc": 0, "results": []}
msg: No Package matching 'ceph-mon' found available, installed or updated

FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/site.sample.retry

magna077                   : ok=23   changed=7    unreachable=0    failed=1



the repo on the remote node:
[root@magna077 ~]# ll /tmp/rh-storage-mount/
total 0
[root@magna077 ~]# 
[root@magna077 ~]# 
[root@magna077 ~]# ll /tmp/rh-storage-repo/
total 56
-r--r--r--. 1 root root  8774 May 24 06:51 EULA
-r--r--r--. 1 root root 18092 May 24 06:51 GPL
dr-xr-xr-x. 3 root root  4096 May 24 06:51 MON
dr-xr-xr-x. 3 root root  4096 May 24 06:51 OSD
-r--r--r--. 1 root root   165 May 24 06:51 README
-r--r--r--. 1 root root  3211 May 24 06:51 RPM-GPG-KEY-redhat-release
dr-xr-xr-x. 3 root root  4096 May 24 06:51 Tools
-r--r--r--. 1 root root  1976 May 24 06:51 TRANS.TBL


ceph_stable_rh_storage: true
#ceph_stable_rh_storage_cdn_install: true # assumes all the nodes can connect to cdn.redhat.com
ceph_stable_rh_storage_iso_install: true # usually used when nodes don't have access to cdn.redhat.com
#ceph_stable_rh_storage_iso_path: /tmp/Ceph-2-Ubuntu-x86_64-20160519.t.0-dvd.iso
ceph_stable_rh_storage_iso_path: /tmp/Ceph-2-RHEL-7-20160520.t.0-x86_64-dvd.iso
#ceph_stable_rh_storage_mount_path: /tmp/rh-storage-mount
#ceph_stable_rh_storage_repository_path: /tmp/rh-storage-repo # where to copy iso's content


the group_vars files and the playbook log are located at :
magna006:/root/bz/monfail

Comment 2 Alfredo Deza 2016-05-24 12:22:35 UTC
Please include in this BZ the full output of the ansible run (and default to this for all ceph-ansible/ceph-installer tickets please). 

It seems that the playbook is not including the part where repos need to be setup for ISO.

Comment 3 Alfredo Deza 2016-05-24 14:14:21 UTC
Pull request opened https://github.com/ceph/ceph-ansible/pull/810

Comment 4 Tejas 2016-05-25 05:40:39 UTC
hi Alfredo,

    I have included the full ansible run in the file:
magna006:/root/bz/monfail/playbooklog

Comment 8 Christina Meno 2016-05-27 22:54:21 UTC
I've had no luck with this issue today. No progress to report.

Comment 9 Alfredo Deza 2016-05-31 13:05:34 UTC
Pull request opened https://github.com/ceph/ceph-ansible/pull/823

Comment 12 Tejas 2016-06-14 07:39:17 UTC
Verified on build:
ceph-ansible-1.0.5-19.el7scon.noarch
ceph version 10.2.1-13.el7cp (f15ca93643fee5f7d32e62c3e8a7016c1fc1e6f4)

Moving to verified state.

Comment 14 errata-xmlrpc 2016-08-23 19:51:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.