Bug 133910 - Initializing hardware sometimes hangs
Summary: Initializing hardware sometimes hangs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 13:49 UTC by Oliver Falk
Modified: 2014-03-17 02:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 14:33:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch adds a commandline switch 'nohwinit' (366 bytes, patch)
2004-09-28 13:51 UTC, Oliver Falk
no flags Details | Diff

Description Oliver Falk 2004-09-28 13:49:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
Sometimes the hardware init hangs (at least with a default Fedora
kernel), there should be some posibility to disable this by a kernel
command line switch...

Version-Release number of selected component (if applicable):
initscript-7.84-1

How reproducible:
Sometimes

Steps to Reproduce:
...

Additional info:

Comment 1 Oliver Falk 2004-09-28 13:51:56 UTC
Created attachment 104436 [details]
This patch adds a commandline switch 'nohwinit'

This patch adds a command line switch 'nohwinit', that disables reading other
modules, so no modules can be modprobed... This will not _fix_ the problem, but
it is a workaround, so you can at least boot up the system...

Comment 2 Davide Bolcioni 2004-10-11 13:54:38 UTC
The same happens here with a minimal install of FC3 test 2 on a P4A845
motherboard and SELinux disabled; the boot process hangs consistently
after initializing storage, network and possibly audio (screen blanks
at this point, not sure). If I manually edit rc.sysinit commenting out
the part about "other" modules, the boot is ok and a suitably placed echo
tells me that the modules it would attempt in the "other" part are:
i8xx_tco hw_random kyrofb uhci-hcd uhci-ucd (the latter twice, it's
not a typo). Attempting modprobe on each, kyrofb hangs the machine.

Comment 3 Davide Bolcioni 2004-10-11 14:03:47 UTC
After the above, I added

  install kyrofb false

in modprobe.conf, which enabled me to undo all above mentioned changes
to rc.sysinit (the host is not intended to use X anyway).

Comment 4 Bill Nottingham 2004-10-11 14:33:38 UTC
This should be fixed in current packages... the framebuffer drivers
are blacklisted from being autoloaded.


Note You need to log in before you can comment on or make changes to this bug.