Bug 133911 - shouldn't depends on the locale to see PDF file
shouldn't depends on the locale to see PDF file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 09:55 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 06:54:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-09-28 09:55:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
PDF format is designed to be possible to see without the dependency of
locale. however xpdf couldn't shows PDF file without setting of proper
locale.
separating the configuration wasn't bad to me, because it avoids to be
screwed up the configuration. since xpdf supports 'include' directive,
/etc/xpdfrc should include all of xpdfrc.* which just has the font
configuration like this:

include /etc/xpdfrc.ko
include /etc/xpdfrc.ja
include /etc/xpdfrc.zh_CN
include /etc/xpdfrc.zh_TW


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.get the pdf file from Bug#123540 say
2.run xpdf with LANG=en_US
3.
    

Actual Results:  no Japanese glyphs are shown

Expected Results:  Japanese glyphs are shown

Additional info:
Comment 2 Ngo Than 2004-10-11 06:54:13 EDT
yes, it will be fixed in next rebuild. Leon, could you please take a
look at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123540.
thanks

Note You need to log in before you can comment on or make changes to this bug.