Bug 1339131 - networkctl status: abort, munmap_chunk(): invalid pointer
Summary: networkctl status: abort, munmap_chunk(): invalid pointer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1343306 1350394 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 08:37 UTC by Jan Včelák
Modified: 2016-07-23 18:48 UTC (History)
11 users (show)

Fixed In Version: systemd-229-9.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-23 18:48:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
patch (725 bytes, patch)
2016-05-24 09:58 UTC, Susant Sahani
no flags Details | Diff

Description Jan Včelák 2016-05-24 08:37:51 UTC
Description of problem:

"networkctl status" is aborted

Version-Release number of selected component (if applicable):
systemd-229-7.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
1. networkctl status
2.
3.

Actual results:

% networkctl status
●        State: n/a
       Address: 147.x.x.x on eno1
                172.x.x.x on vpn-xxxxx
                2001::xxx on eno1
                2001::xxx on eno1
                2001::xxx on eno1
                2001::xxx on vpn-xxxxx
                2001::xxx on vpn-xxxxx
                2001::xxx on vpn-xxxxx
                fe80::xxx on eno1
                fe80::xxx on vpn-xxxxx
       Gateway: 147.x.x.x (Extreme Networks) on eno1
                fe80::xxx (Extreme Networks) on eno1
                fe80::xxx on vpn-xxxxx
 Route Domains: help
*** Error in `networkctl': munmap_chunk(): invalid pointer: 0x00005633149af502 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x75dbb)[0x7f60a5a69dbb]
/lib64/libc.so.6(cfree+0x1a8)[0x7f60a5a75c28]
networkctl(+0xd989)[0x5633149a2989]
networkctl(+0x17e66)[0x5633149ace66]
networkctl(+0x4cb5)[0x563314999cb5]
/lib64/libc.so.6(__libc_start_main+0xf1)[0x7f60a5a14731]
networkctl(+0x50b9)[0x56331499a0b9]
======= Memory map: ========
563314995000-5633149b7000 r-xp 00000000 fd:01 528825                     /usr/bin/networkctl
5633149b8000-563314a3a000 r--p 00022000 fd:01 528825                     /usr/bin/networkctl
563314a3a000-563314a3b000 rw-p 000a4000 fd:01 528825                     /usr/bin/networkctl
56331589d000-5633158be000 rw-p 00000000 00:00 0                          [heap]
7f609e9ce000-7f60a5341000 r--p 00000000 fd:01 528259                     /usr/lib/locale/locale-archive
7f60a5341000-7f60a59f4000 r--s 00000000 fd:01 1442463                    /etc/udev/hwdb.bin
7f60a59f4000-7f60a5bad000 r-xp 00000000 fd:01 547450                     /usr/lib64/libc-2.23.so
7f60a5bad000-7f60a5dad000 ---p 001b9000 fd:01 547450                     /usr/lib64/libc-2.23.so
7f60a5dad000-7f60a5db1000 r--p 001b9000 fd:01 547450                     /usr/lib64/libc-2.23.so
7f60a5db1000-7f60a5db3000 rw-p 001bd000 fd:01 547450                     /usr/lib64/libc-2.23.so
7f60a5db3000-7f60a5db7000 rw-p 00000000 00:00 0 
7f60a5db7000-7f60a5dce000 r-xp 00000000 fd:01 547475                     /usr/lib64/libpthread-2.23.so
7f60a5dce000-7f60a5fcd000 ---p 00017000 fd:01 547475                     /usr/lib64/libpthread-2.23.so
7f60a5fcd000-7f60a5fce000 r--p 00016000 fd:01 547475                     /usr/lib64/libpthread-2.23.so
7f60a5fce000-7f60a5fcf000 rw-p 00017000 fd:01 547475                     /usr/lib64/libpthread-2.23.so
7f60a5fcf000-7f60a5fd3000 rw-p 00000000 00:00 0 
7f60a5fd3000-7f60a5fe9000 r-xp 00000000 fd:01 547437                     /usr/lib64/libgcc_s-6.1.1-20160510.so.1
7f60a5fe9000-7f60a61e8000 ---p 00016000 fd:01 547437                     /usr/lib64/libgcc_s-6.1.1-20160510.so.1
7f60a61e8000-7f60a61e9000 r--p 00015000 fd:01 547437                     /usr/lib64/libgcc_s-6.1.1-20160510.so.1
7f60a61e9000-7f60a61ea000 rw-p 00016000 fd:01 547437                     /usr/lib64/libgcc_s-6.1.1-20160510.so.1
7f60a61ea000-7f60a61f1000 r-xp 00000000 fd:01 547479                     /usr/lib64/librt-2.23.so
7f60a61f1000-7f60a63f0000 ---p 00007000 fd:01 547479                     /usr/lib64/librt-2.23.so
7f60a63f0000-7f60a63f1000 r--p 00006000 fd:01 547479                     /usr/lib64/librt-2.23.so
7f60a63f1000-7f60a63f2000 rw-p 00007000 fd:01 547479                     /usr/lib64/librt-2.23.so
7f60a63f2000-7f60a6415000 r-xp 00000000 fd:01 525592                     /usr/lib64/ld-2.23.so
7f60a65f0000-7f60a65f4000 rw-p 00000000 00:00 0 
7f60a660c000-7f60a660d000 rw-p 00000000 00:00 0 
7f60a660d000-7f60a6614000 r--s 00000000 fd:01 656874                     /usr/lib64/gconv/gconv-modules.cache
7f60a6614000-7f60a6615000 rw-p 00000000 00:00 0 
7f60a6615000-7f60a6616000 r--p 00023000 fd:01 525592                     /usr/lib64/ld-2.23.so
7f60a6616000-7f60a6617000 rw-p 00024000 fd:01 525592                     /usr/lib64/ld-2.23.so
7f60a6617000-7f60a6618000 rw-p 00000000 00:00 0 
7ffe001a1000-7ffe001c3000 rw-p 00000000 00:00 0                          [stack]
7ffe001d3000-7ffe001d6000 r--p 00000000 00:00 0                          [vvar]
7ffe001d6000-7ffe001d8000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
[1]    17361 abort      networkctl status


Expected results:


Additional info:

Comment 1 Jan Synacek 2016-05-24 09:50:55 UTC
Wow, systemd should really be tested for such trivial use cases.

Comment 2 Susant Sahani 2016-05-24 09:56:52 UTC
yes really reproduced.


Program received signal SIGABRT, Aborted.
0x00007ffff740fe55 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
54	  return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
(gdb) bt
#0  0x00007ffff740fe55 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#1  0x00007ffff7411a5a in __GI_abort () at abort.c:89
#2  0x00007ffff7450dc0 in __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7ffff7567ac0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
#3  0x00007ffff745cc28 in malloc_printerr (ar_ptr=0x0, ptr=<optimized out>, str=0x7ffff7567ae8 "munmap_chunk(): invalid pointer", action=<optimized out>) at malloc.c:5004
#4  munmap_chunk (p=<optimized out>) at malloc.c:2840
#5  __GI___libc_free (mem=<optimized out>) at malloc.c:2961
#6  0x00005555555619c9 in strv_clear () at src/basic/strv.c:83
#7  strv_free (l=0x5555555f87c0 <options>) at src/basic/strv.c:89
#8  0x000055555556be04 in strv_freep () at ./src/basic/strv.h:37
#9  link_status.lto_priv.140 (argc=<optimized out>, argv=<optimized out>, userdata=<optimized out>) at src/network/networkctl.c:679
#10 0x0000555555558d08 in dispatch_verb (userdata=0x0, verbs=0x7fffffffdc10, argv=0x7fffffffded8, argc=<optimized out>) at src/basic/verbs.c:92
#11 networkctl_main (argv=0x7fffffffded8, argc=<optimized out>) at src/network/networkctl.c:1093
#12 main (argc=<optimized out>, argv=0x7fffffffded8) at src/network/networkctl.c:1106
(gdb) f 9
#9  link_status.lto_priv.140 (argc=<optimized out>, argv=<optimized out>, userdata=<optimized out>) at src/network/networkctl.c:679
679	                _cleanup_strv_free_ char **dns = NULL, **ntp = NULL, **search_domains = NULL, **route_domains;
(gdb) q
A debugging session is active.

	Inferior 1 [process 13639] will be killed.

Comment 3 Susant Sahani 2016-05-24 09:58:18 UTC
Created attachment 1160970 [details]
patch

Comment 5 Jan Synacek 2016-06-07 07:01:17 UTC
*** Bug 1343306 has been marked as a duplicate of this bug. ***

Comment 6 Susant Sahani 2016-06-28 03:55:21 UTC
*** Bug 1350394 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2016-07-21 06:46:52 UTC
systemd-229-9.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-47bda25e7a

Comment 8 Fedora Update System 2016-07-21 18:52:47 UTC
systemd-229-9.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-47bda25e7a

Comment 9 Fedora Update System 2016-07-23 18:47:55 UTC
systemd-229-9.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.