Bug 1339138 - fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.
Summary: fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: fuse
Version: 3.7.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Olia Kremmyda
QA Contact:
URL:
Whiteboard:
Depends On: 1338544
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 08:45 UTC by Niels de Vos
Modified: 2016-08-02 07:24 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.7.14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1338544
Environment:
Last Closed: 2016-08-02 07:24:32 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2016-05-24 08:45:24 UTC
+++ This bug was initially created as a clone of Bug #1338544 +++

Description of problem:
In fuse_first_lookup function, "dict_unref (dict)" should be included in the out label, in case create_frame returns an empty pointer the dict to be unreferenced as well.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Vijay Bellur on 2016-05-22 20:07:02 CEST ---

REVIEW: http://review.gluster.org/14463 (fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.) posted (#1) for review on release-3.7 by Olia Kremmyda (olympia.kremmyda@nokia.com)

--- Additional comment from Vijay Bellur on 2016-05-22 20:42:37 CEST ---

REVIEW: http://review.gluster.org/14464 (fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.) posted (#1) for review on master by Olia Kremmyda (olympia.kremmyda@nokia.com)

--- Additional comment from Vijay Bellur on 2016-05-22 20:44:56 CEST ---

REVIEW: http://review.gluster.org/14464 (fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.) posted (#2) for review on master by Olia Kremmyda (olympia.kremmyda@nokia.com)

--- Additional comment from Vijay Bellur on 2016-05-22 22:39:48 CEST ---

REVIEW: http://review.gluster.org/14465 (fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.) posted (#1) for review on release-3.8 by Olia Kremmyda (olympia.kremmyda@nokia.com)

--- Additional comment from Vijay Bellur on 2016-05-23 15:31:23 CEST ---

REVIEW: http://review.gluster.org/14464 (fuse: unref dict even if fuse_first_lookup fails) posted (#3) for review on master by Jeff Darcy (jdarcy@redhat.com)

--- Additional comment from Vijay Bellur on 2016-05-23 15:33:58 CEST ---

COMMIT: http://review.gluster.org/14464 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit b01fb8d3bb9772d94073aaa52b2d8210ac4fabb8
Author: Kremmyda, Olia (NSN - GR/Athens) <olympia.kremmyda@nokia.com>
Date:   Sun May 22 21:40:19 2016 +0300

    fuse: unref dict even if fuse_first_lookup fails
    
    In fuse_first_lookup function, "dict_unref (dict)" should be included in
    the out label, in case create_frame returns an empty pointer the dict to
    be unreferenced as well.
    
    
    Bug: 1338544
    Change-Id: Ifb8a3378aec6521c1aa848f818968b6bfdb72089
    Signed-off-by: Olia Kremmyda <olympia.kremmyda@nokia.com>
    Reviewed-on: http://review.gluster.org/14464
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 1 Vijay Bellur 2016-05-24 08:47:37 UTC
REVIEW: http://review.gluster.org/14463 (fuse: In fuse_first_lookup(), dict is not un-referenced in case create_frame returns an empty pointer.) posted (#2) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 2 Vijay Bellur 2016-05-24 08:48:36 UTC
REVIEW: http://review.gluster.org/14463 (fuse: unref dict even if fuse_first_lookup fails) posted (#3) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 3 Vijay Bellur 2016-05-24 08:50:35 UTC
REVIEW: http://review.gluster.org/14463 (fuse: unref dict even if fuse_first_lookup fails) posted (#4) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)

Comment 4 Vijay Bellur 2016-07-17 21:35:14 UTC
COMMIT: http://review.gluster.org/14463 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 338aa4634fe0aa8723349763871b3933b14d54ff
Author: Kremmyda, Olia (NSN - GR/Athens) <olympia.kremmyda@nokia.com>
Date:   Sun May 22 19:04:05 2016 +0300

    fuse: unref dict even if fuse_first_lookup fails
    
    In fuse_first_lookup function, "dict_unref (dict)" should be included in
    the out label, in case create_frame returns an empty pointer the dict to
    be unreferenced as well.
    
    Backport of commit b01fb8d3bb9772d94073aaa52b2d8210ac4fabb8:
    > Bug: 1338544
    > Change-Id: Ifb8a3378aec6521c1aa848f818968b6bfdb72089
    > Signed-off-by: Olia Kremmyda <olympia.kremmyda@nokia.com>
    > Reviewed-on: http://review.gluster.org/14464
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Smoke: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    Bug: 1339138
    Change-Id: I5c26740ecf8e4344a3150e1f9ac9bdcaec22d819
    Signed-off-by: Olia Kremmyda <olympia.kremmyda@nokia.com>
    Reviewed-on: http://review.gluster.org/14463
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 5 Kaushal 2016-08-02 07:24:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.14, please open a new bug report.

glusterfs-3.7.14 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-August/050319.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.