Bug 1339175 - [NetKVM] Turn on RSC feature in NetKVM driver
Summary: [NetKVM] Turn on RSC feature in NetKVM driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 10:27 UTC by Yan Vugenfirer
Modified: 2016-11-04 08:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update adds support for the RSC feature to the virtio-net (NetKVM) Windows guest driver. The support is included in all driver versions targeted at Windows Server 2012 and up. RSC (Receive Segment Coalescing) enables the driver to report coalesced TCP segments to the OS. https://msdn.microsoft.com/en-us/windows/hardware/drivers/network/receive-segment-coalescing--rsc-
Clone Of:
Environment:
Last Closed: 2016-11-04 08:54:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yan Vugenfirer 2016-05-24 10:27:45 UTC
Description of problem:

Currently RSC feature is disabled in compilation time. We should enable it and test the driver with this feature turned on.

What to tests:

* Run part of the test plan related to network traffic.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Adam Mariš 2016-05-24 12:47:34 UTC
What does make this bug security sensitive?

Comment 2 Yan Vugenfirer 2016-05-25 07:00:46 UTC
(In reply to Adam Mariš from comment #1)
> What does make this bug security sensitive?

It is not security sensitive. I don't know why there is "security" in keywords field. I am removing it to prevent confusion.

Comment 8 lijin 2016-09-02 07:30:33 UTC
with virtio-win-prewhql-126,rsc feature is turned on,rsc related job can be loaded when run netkvm whql test.And job can pass(with filter/errata)

So change status to verified.

Comment 10 errata-xmlrpc 2016-11-04 08:54:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.