Bug 133919 - Nautilus cannot display directories in USB external disk other than the topmost one
Summary: Nautilus cannot display directories in USB external disk other than the topmo...
Status: CLOSED DUPLICATE of bug 129966
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-28 14:32 UTC by Rodger Wang
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:05:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OK--gzipping did the trick (213.68 KB, text/plain)
2004-10-01 15:19 UTC, Don Hardaway
no flags Details

Description Rodger Wang 2004-09-28 14:32:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040926
Firefox/0.10

Description of problem:
FC3T2 can correctly mount my USB external disk's 2 partitions(FAT32),
and I can use CLI and other GUI applications to access the whole disk
contents without any problem. But, Nautilus can only open the top
level directory, not any further. I always got the error message
'openning xxx, you can stop this operation by clicking cancel.'.



Version-Release number of selected component (if applicable):
nautilus-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. plug in the USB external HD
2. boot the system into GNOME 2.8
3. there are two USB disk icons on the desktop
4. double-click on one of them to open the top level directory list
5. double-click on any of the sub-directoy icons
    

Actual Results:  the sub-directory won't be opened. Message 'openning
xxx, you can stop this operation by clicking cancel.' will show after
a couple of seconds

Expected Results:  it should open a new directory window to show
sub-directory content

Additional info:

Comment 1 Alexander Larsson 2004-09-29 08:02:33 UTC
Can you get an strace of when this happens?

Comment 2 Rodger Wang 2004-09-29 10:22:52 UTC
I am not an Linux expert. Can you tell me the whole command?

Comment 3 Alexander Larsson 2004-09-29 12:06:58 UTC
remove nautilus from the session (so it doesn't restart), kill it, and
then run "strace -o nautilus.log -tt -f nautilus", navigate to the
disk where it hangs, and attach nautilus.log here.

Comment 4 Alexander Larsson 2004-10-01 08:41:59 UTC
bug 129966 seems very similar, but on fc2 due to a kernel upgrade, so
this might be kernel related.

Comment 5 Don Hardaway 2004-10-01 10:25:53 UTC
This is exactly my problem also--I am bug 129966.

Comment 6 Don Hardaway 2004-10-01 10:58:15 UTC
I have the strace you requested but it will not let me attached it. It
says it is too big.  What do you want me to do??

Comment 7 Alexander Larsson 2004-10-01 14:17:08 UTC
How big is it if you gzip it?

Comment 8 Don Hardaway 2004-10-01 15:19:57 UTC
Created attachment 104631 [details]
OK--gzipping did the trick

Here you go.

Comment 9 Alexander Larsson 2004-10-04 07:38:35 UTC
Do you get any messages in /var/log/messages when this happens?

Also, what sort of filenames are in the directory, and how does the
mount command line for the filesystem in /etc/fstab?

Comment 10 Don Hardaway 2004-10-04 12:17:57 UTC
Need to merge this bug with 129966.

Comment 11 Alexander Larsson 2004-10-04 13:16:39 UTC

*** This bug has been marked as a duplicate of 129966 ***

Comment 12 Red Hat Bugzilla 2006-02-21 19:05:57 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.