Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1339278 - Owncloud-client does not work with normal user's credentials, but it does with administrative credentials
Summary: Owncloud-client does not work with normal user's credentials, but it does wit...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: owncloud-client
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Nikos Roussos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 14:34 UTC by Boricua
Modified: 2016-06-02 20:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-02 20:22:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Boricua 2016-05-24 14:34:06 UTC
Description of problem:
Latest owncloud-clients for Fedora 24 does not start as expected while login in, but it does with the sudo command.

Version-Release number of selected component (if applicable):
2.2.0-4

How reproducible:
Every time I log in.

Steps to Reproduce:
1.Log in (the client does not appear, but a service is running)
2.Open a terminal and issue command "sudo owncloud" and enter password.
3.The client's wizard appears.

Actual results:
No normal user owncloud-client service available.

Expected results:
A normal user owncloud-client service running after log in.

Additional info:
I have several desktops running Fedora 23 and 24, but this behavior only happens in my brand new ThinkPad T460s. After loging in, I can see an owncloud service running in the system monitor, but no icon nor sync taking place. If I launch the client from a terminal as a normal user, I get this:

[francisco@localhost ~]$ owncloud
(owncloud:3634): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'
(owncloud:3634): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(owncloud:3634): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
(owncloud:3634): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(owncloud:3634): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(owncloud:3634): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(owncloud:3634): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
(owncloud:3634): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'
(owncloud:3634): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(owncloud:3634): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed
(owncloud:3634): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed
(owncloud:3634): GLib-GObject-CRITICAL **: g_object_new: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

If I launch the client with the sudo command, it works.

Comment 1 Nikos Roussos 2016-05-26 06:35:37 UTC
Can you update to see if the error persists? Latest is owncloud-client-2.2.0-8

Comment 2 Boricua 2016-05-26 15:03:05 UTC
I just tried and the error remains the same for the ThinkPad. Updates in my other stations to owncloud-client-2.2.0-8 went well.

Comment 3 Boricua 2016-06-02 20:08:11 UTC
Since I was not sure this was really an owncloud-client issue, I decided to reinstall everything with Fedora 24 Beta. Now, owncloud-client seems to be working just fine with version 2.2.0-8. I suggest we can close this bug report.

Comment 4 Nikos Roussos 2016-06-02 20:22:50 UTC
Thanks


Note You need to log in before you can comment on or make changes to this bug.