Bug 1339298 - mod_ssl upgrade breaks Satellite deployed httpd
Summary: mod_ssl upgrade breaks Satellite deployed httpd
Keywords:
Status: CLOSED DUPLICATE of bug 1336365
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 15:31 UTC by Evgeni Golov
Modified: 2016-05-25 08:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-25 08:58:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Evgeni Golov 2016-05-24 15:31:44 UTC
Description of problem:
Running 6.2 beta on RHEL7.2, got the mod_ssl-2.4.6-40.el7_2.1.x86_64 update yesterday. After deploying it, httpd won't start as there are now two "Listen 443" directives:
[root@sat62 ~]# grep -r "Listen.*443" /etc/httpd/
/etc/httpd/conf.d/ssl.conf:Listen 443 https
/etc/httpd/conf/ports.conf:Listen 443
and these lead to
httpd[10568]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
When the parser hits the second one.

Version-Release number of selected component (if applicable):
satellite-6.2.0-9.0.beta.el7sat.noarch

How reproducible:
didn't try.

Steps to Reproduce:
1. install satellite before the mod_ssl update
2. update mod_ssl
3. restart httpd

Actual results:
httpd[10568]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443

Expected results:
httpd starts

Additional info:

Comment 1 Tomer Brisker 2016-05-25 08:58:17 UTC

*** This bug has been marked as a duplicate of bug 1336365 ***


Note You need to log in before you can comment on or make changes to this bug.