Bug 1339379 - [python-mimeparse] switch to new upstream source
Summary: [python-mimeparse] switch to new upstream source
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mimeparse
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-24 20:26 UTC by Carl George
Modified: 2017-05-23 03:24 UTC (History)
3 users (show)

Fixed In Version: python-mimeparse-1.6.0-2.fc25 python-mimeparse-1.6.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 06:01:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1339367 None CLOSED falcon-1.0.0 is available 2019-01-02 19:26:23 UTC

Internal Links: 1339367

Description Carl George 2016-05-24 20:26:41 UTC
Description of problem:
The current upstream for this package hasn't been maintained since 2013 [1].  A fork exists [2] that is actively maintained and is using the name python-mimeparse on PyPI.  Recently I noticed that falcon's test suite actually requires the newer fork [3].  It would be beneficial if the python-mimeparse package switched to use the python-mimeparse module as the upstream source.

Version-Release number of selected component (if applicable):
0.1.4-8.fc24

Additional info:
I have also raised a bug with the newer project to suggest a merge back with the original module/name [4].

[1]: https://code.google.com/archive/p/mimeparse/source/default/commits
[2]: https://github.com/dbtsai/python-mimeparse
[3]: https://bugzilla.redhat.com/show_bug.cgi?id=1339367
[4]: https://github.com/dbtsai/python-mimeparse/issues/20

Comment 1 Jan Kurik 2016-07-26 04:25:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 2 Carl George 2017-01-02 19:41:40 UTC
I have requested to become a co-maintainer in pkgdb, so that I can implement this myself.

Comment 3 Carl George 2017-01-05 20:01:25 UTC
Falcon 1.1.0 now directly requires mimeparse>=1.5.2, so this is blocking my update.

https://github.com/falconry/falcon/commit/5493bf8

Comment 4 Rex Dieter 2017-01-05 20:13:40 UTC
marking FutureFeature, so this bug won't get autoclosed

Comment 5 Carl George 2017-02-13 14:56:20 UTC
I would like to move forward with fixing this.  Can a maintainer of this package please respond?

Comment 7 Fedora Update System 2017-05-04 15:25:40 UTC
python-mimeparse-1.6.0-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b96f2133c1

Comment 8 Fedora Update System 2017-05-04 15:25:46 UTC
python-mimeparse-1.6.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a3491137af

Comment 9 Fedora Update System 2017-05-05 21:01:24 UTC
python-mimeparse-1.6.0-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b96f2133c1

Comment 10 Fedora Update System 2017-05-06 04:56:15 UTC
python-mimeparse-1.6.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a3491137af

Comment 11 Fedora Update System 2017-05-16 06:01:04 UTC
python-mimeparse-1.6.0-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-05-23 03:24:44 UTC
python-mimeparse-1.6.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.