Bug 1339420 - bash-completion-extras provides files provided by RHEL bash-completion package
Summary: bash-completion-extras provides files provided by RHEL bash-completion package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bash-completion-extras
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jim Perrin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 01:52 UTC by Aaron Howell
Modified: 2016-07-15 14:16 UTC (History)
2 users (show)

Fixed In Version: bash-completion-extras-2.1-11.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 14:16:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Aaron Howell 2016-05-25 01:52:36 UTC
Description of problem:
bash-completion-extras provides files provided by RHEL bash-completion package

Version-Release number of selected component (if applicable):
bash-completion-extras-2.1-8.el7.noarch
bash-completion-2.1-6.el7.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. comm -1 -2 <(rpm -ql bash-completion | sort) <(rpm -ql bash-completion-extras | sort)

Actual results:
/usr/share/bash-completion/bash_completion
/usr/share/bash-completion/completions
/usr/share/bash-completion/completions/find
/usr/share/bash-completion/completions/ip
/usr/share/bash-completion/completions/mount
/usr/share/bash-completion/completions/passwd
/usr/share/bash-completion/completions/ping
/usr/share/bash-completion/completions/quota
/usr/share/bash-completion/completions/ssh
/usr/share/bash-completion/completions/sudo
/usr/share/bash-completion/completions/useradd
/usr/share/bash-completion/completions/userdel
/usr/share/bash-completion/completions/usermod
/usr/share/bash-completion/completions/xz

Expected results:
/usr/share/bash-completion/completions

Additional info:
This package should only provide additional files, currently no conflicts - but wouldn't want it to occur.

Comment 1 Jim Perrin 2016-05-25 13:42:03 UTC
Confirmed. I'll have fixed update out soon.

Comment 2 Fedora Update System 2016-05-27 16:25:05 UTC
bash-completion-extras-2.1-10.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1db95de7a7

Comment 3 Fedora Update System 2016-05-28 03:17:50 UTC
bash-completion-extras-2.1-10.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1db95de7a7

Comment 4 Tuomo Soini 2016-05-28 09:51:08 UTC
One more conflict in bash-completion-extras-2.1-10.el7.

rpm -qf /usr/share/bash-completion/completions/rpm

rpm-4.11.3-17.el7.x86_64
bash-completion-extras-2.1-10.el7.noarch

I'd add

Requires: /usr/share/bash-completion/completions/rpm

so that symlinks can still be provided in bash-completion-extras package or rename rpm to rpmbuild so there is no need for dependency or symlink.

Comment 5 Aaron Howell 2016-06-14 01:32:54 UTC
Good pickup - I had only checked those files provided in the bash-completion package.

Small script to check for dupes (which confirms rpm)

for EACH in /usr/share/bash-completion/completions/*; do if [ $(rpm -qf $EACH | wc -l) -gt 1 ]; then echo $EACH; rpm -qf $EACH; fi; done
/usr/share/bash-completion/completions/rpm
rpm-4.11.3-17.el7.x86_64
bash-completion-extras-2.1-10.el7.noarch

Cheers
Aaron

Comment 6 Tuomo Soini 2016-06-14 08:23:02 UTC
You only check for installed packages. I used yum provides lookup to find out all conflicts and rpm was only one I could find.

Comment 7 Jim Perrin 2016-06-16 17:52:12 UTC
I let this go longer than I should have. -11 should have rpm removed as well. will push/build momentarily

Comment 8 Aaron Howell 2016-06-16 23:53:45 UTC
(In reply to Tuomo Soini from comment #6)
> You only check for installed packages. I used yum provides lookup to find
> out all conflicts and rpm was only one I could find.

Can't believe I can say this. Code or it didn't happen! :)

It's a good idea - this is what I came up with (uses repoquery which is better to use than yum in scripts) - might help as a test for this package (Only thing is its slow)
for EACH in $(sudo repoquery --plugins -q --list bash-completion-extras | grep "^/usr/share/bash-completion/completions/"); do if [ $(sudo repoquery --plugins -q --whatprovides $EACH | wc -l) -gt 1 ]; then echo -e "\n$EACH"; else echo -n "."; fi; done

Comment 10 Fedora Update System 2016-06-28 13:04:44 UTC
bash-completion-extras-2.1-11.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-57322c5a9c

Comment 11 Fedora Update System 2016-06-29 21:50:17 UTC
bash-completion-extras-2.1-11.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-57322c5a9c

Comment 12 Fedora Update System 2016-07-15 14:16:47 UTC
bash-completion-extras-2.1-11.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.