Bug 1339439 - [ceph-ansible] : ISO installation fails with error ' Package <pkg name> is not signed'
Summary: [ceph-ansible] : ISO installation fails with error ' Package <pkg name> is no...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 2
Assignee: Andrew Schoen
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks: 1343229
TreeView+ depends on / blocked
 
Reported: 2016-05-25 03:34 UTC by Rachana Patel
Modified: 2016-08-23 19:51 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-ansible-1.0.5-20.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:51:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
all file (10.83 KB, text/plain)
2016-05-25 03:34 UTC, Rachana Patel
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Rachana Patel 2016-05-25 03:34:16 UTC
Created attachment 1161290 [details]
all file

Description of problem:
=======================
On RHEL node ceph installation via ISO fails in Task 'install distro or red hat storage ceph mon' saying 
'Package ceph-base-10.2.1-7.el7cp.x86_64.rpm is not signed'



Version-Release number of selected component (if applicable):
===============================================================
10.2.1-7.el7cp.x86_64.rpm
ceph-ansible-1.0.5-16.el7scon.noarch



How reproducible:
=================
always


Steps to Reproduce:
===================
1. do all pre installation steps on all cluster node
2. modify variable as mentioned in section 3.2.2 of doc
(please refer attachment for 'all' file)
3. copy ISO on installer node @ /root
and give that path  to
ceph_stable_rh_storage_iso_path: 

4. run below command 

[root@magna051 ceph-ansible]#  ansible-playbook site.yml -vv -i  /etc/ansible/hosts  


Actual results:
===============
Package ceph-base-10.2.1-7.el7cp.x86_64.rpm is not signed


FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/site.retry

magna084                   : ok=29   changed=3    unreachable=0    failed=1   






Additional info:
================
on node repo file content:-

[root@magna084 ubuntu]# cat /etc/yum.repos.d/rh_storage.repo 
# Please do not change this file directly since it is managed by Ansible and will be overwritten
[rh_storage_mon]
name=Red Hat Storage Ceph - local packages for Ceph
baseurl=file:///tmp/rh-storage-repo/MON
enabled=1
gpgcheck=1
type=rpm-md
priority=1
gpgkey=file:///tmp/rh-storage-repo/RPM-GPG-KEY-redhat-release

[rh_storage_osd]
name=Red Hat Storage Ceph - local packages for Ceph
baseurl=file:///tmp/rh-storage-repo/OSD
enabled=1
gpgcheck=1
type=rpm-md
priority=1
gpgkey=file:///tmp/rh-storage-repo/RPM-GPG-KEY-redhat-release

[rh_storage_tools]
name=Red Hat Storage Ceph - assorted tools
baseurl=file:///tmp/rh-storage-repo/Tools
enabled=1
gpgcheck=1
type=rpm-md
priority=1
gpgkey=file:///tmp/rh-storage-repo/RPM-GPG-KEY-redhat-release

Comment 7 Andrew Schoen 2016-06-01 19:06:00 UTC
Upstream pull request opened: https://github.com/ceph/ceph-ansible/pull/832

Comment 10 Rachana Patel 2016-07-28 19:54:18 UTC
verified with 

ceph-ansible-1.0.5-31.el7scon.noarch
ceph - 10.2.2-29.el7cp.x86_64

- executed command mentioned in Comment#9, working as expected hence moving to verified.

Comment 12 errata-xmlrpc 2016-08-23 19:51:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.