Bug 1339467 - User cannot create windows 7 virtual machine in rhevm 3.6.5.
Summary: User cannot create windows 7 virtual machine in rhevm 3.6.5.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: pre-dev-freeze
: ---
Assignee: Gerd Hoffmann
QA Contact: Guo, Zhiyi
URL:
Whiteboard:
Depends On:
Blocks: 1371952
TreeView+ depends on / blocked
 
Reported: 2016-05-25 06:29 UTC by Yoshinori Takahashi
Modified: 2019-11-14 08:09 UTC (History)
24 users (show)

Fixed In Version: qemu-kvm-rhev-2.6.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1371952 (view as bug list)
Environment:
Last Closed: 2016-11-07 21:12:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Yoshinori Takahashi 2016-05-25 06:29:24 UTC
Description of problem:

Customer creates windows 7 virtual machine with iso but can not install windows7.

Customer meets starting windows screen but there is no any change progress.
Customer can not see language setting and install button.


Version-Release number of selected component (if applicable):

# rpm -qa | grep rhevm
rhevm-setup-plugin-ovirt-engine-common-3.6.5.3-0.1.el6.noarch
rhevm-log-collector-3.6.1-1.el6ev.noarch
rhevm-restapi-3.6.5.3-0.1.el6.noarch
rhevm-setup-plugin-vmconsole-proxy-helper-3.6.5.3-0.1.el6.noarch
rhevm-webadmin-portal-3.6.5.3-0.1.el6.noarch
rhevm-reports-setup-3.6.5.1-1.el6ev.noarch
rhevm-spice-client-x86-cab-3.6-6.el6.noarch
rhevm-tools-backup-3.6.5.3-0.1.el6.noarch
rhevm-dbscripts-3.6.5.3-0.1.el6.noarch
rhevm-setup-plugins-3.6.4-1.el6ev.noarch
rhevm-doc-3.6.0-6.el6eng.noarch
rhevm-websocket-proxy-3.6.5.3-0.1.el6.noarch
rhevm-spice-client-x64-msi-3.6-6.el6.noarch
rhevm-reports-3.6.5.1-1.el6ev.noarch
rhevm-setup-base-3.6.5.3-0.1.el6.noarch
rhevm-dwh-setup-3.6.2-1.el6ev.noarch
rhevm-iso-uploader-3.6.0-1.el6ev.noarch
rhevm-branding-rhev-3.6.0-9.el6ev.noarch
rhevm-spice-client-x86-msi-3.6-6.el6.noarch
rhevm-setup-plugin-ovirt-engine-3.6.5.3-0.1.el6.noarch
rhevm-dependencies-3.6.0-1.el6ev.noarch
rhevm-backend-3.6.5.3-0.1.el6.noarch
rhevm-setup-3.6.5.3-0.1.el6.noarch
rhevm-image-uploader-3.6.0-1.el6ev.noarch
rhevm-extensions-api-impl-3.6.5.3-0.1.el6.noarch
rhevm-spice-client-x64-cab-3.6-6.el6.noarch
rhevm-doc-ja-JP-3.6.0-3.el6eng.noarch
rhevm-setup-plugin-websocket-proxy-3.6.5.3-0.1.el6.noarch
rhevm-vmconsole-proxy-helper-3.6.5.3-0.1.el6.noarch
rhevm-userportal-3.6.5.3-0.1.el6.noarch
rhevm-sdk-python-3.6.5.0-1.el6ev.noarch
rhevm-3.6.5.3-0.1.el6.noarch
rhevm-lib-3.6.5.3-0.1.el6.noarch
rhevm-cli-3.6.2.0-1.el6ev.noarch
rhevm-dwh-3.6.2-1.el6ev.noarch
rhevm-tools-3.6.5.3-0.1.el6.noarch


How reproducible:


Steps to Reproduce:
1. Create windows 7 virtual machine.
2. Attach IDE storage disk
3. Start with Run once and set windows 7 iso image.
4. Connect spice console 
5. No change after showing "starting windows"


Actual results:

Can not install windows 7 32bit or 64bit version. included all versions like pro, enterprise,home and so on.

Expected results:

Install windows 7 without any error.


Additional info:

Snip from engine.log.

2016-05-23 17:44:05,133 ERROR [org.ovirt.engine.core.vdsbroker.VmsMonitoring] (ForkJoinPool-1-worker-1) [] VM '8faad738-6d18-484f-a82d-9059a92e78b4' managed non pluggable device was removed unexpectedly from libvirt: 'VmDevice:{id='VmDeviceId:{deviceId='768767d1-ae6b-4b1b-a2dc-c7adb2b7597b', vmId='8faad738-6d18-484f-a82d-9059a92e78b4'}', device='cdrom', type='DISK', bootOrder='0', specParams='[path=]', address='', managed='true', plugged='false', readOnly='true', deviceAlias='', customProperties='[]', snapshotId='null', logicalName='null', usingScsiReservation='false'}'

Comment 3 Michal Skrivanek 2016-05-26 04:51:22 UTC
Can you please confirm the OS Type selected for this VM in Edit VM properties? Is it properly set to Windows 7?

Comment 6 Michal Skrivanek 2016-05-26 07:42:16 UTC
can you try virtio-blk interface (not IDE) for the disk, and afterwards use the correct driver from windows-guest-tools during installation?

Comment 19 Matt Smith 2016-06-10 15:58:29 UTC
VM OS selected is Windows 7 x64.

Attempted with ISO's:
-Win7x64 (multiple builds, including latest)
-Win7x32
-2008R2

Attempted with storage:
-IDE
-Virtio
-None (no disks attached to VM)

Disabled VM devices:
-USB
-Virtio SCSI
-Spice clip & transfer
-Souncard

Last working with:
-RHEV-m 3.5 
-Hypervisors RHEL 6.7

Current build:
-RHEV-M 3.6
-Hypervisors RHEL 7.2 (updates applied June 7)

Comment 20 Vinzenz Feenstra [evilissimo] 2016-06-13 13:55:43 UTC
I can start to reproduce this issue with rhev-2.3.0-31.el7_2.13 
rhev-2.3.0-31.el7_2.12 does not have this issue.

Comment 30 Miroslav Rezanina 2016-06-16 05:45:20 UTC
Fix included in qemu-kvm-rhev-2.6.0-7.el7

Comment 32 Bronce McClain 2016-06-16 12:08:06 UTC
snagar, is it possible to get a PM Approval on a z-stream inclusion for this one?

Comment 38 Matt Smith 2016-07-18 12:41:02 UTC
Tested fixed on vdsm-4.17.31-0.el7ev

Comment 44 errata-xmlrpc 2016-11-07 21:12:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.