Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1339481 - Available pool quantity is wrong after removed subscribed pool(by virt-who)
Summary: Available pool quantity is wrong after removed subscribed pool(by virt-who)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: John Mitsch
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 07:35 UTC by Liushihui
Modified: 2019-09-26 14:00 UTC (History)
6 users (show)

Fixed In Version: rubygem-katello-3.0.0.50-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:05:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
pool_quantity (460.00 KB, application/x-gzip)
2016-05-25 07:36 UTC, Liushihui
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15394 0 Normal Closed Available pool quantity is wrong after removed subscribed pool(by virt-who) 2020-07-17 06:02:34 UTC

Description Liushihui 2016-05-25 07:35:23 UTC
Description of problem:
After removed subscribed pool, it can't add the removed pools to available list.

Version-Release number of selected component (if applicable):
Satellite-6.2.0-RHEL-7-20160518
virt-who-0.17-1.el7.noarch
subscription-manager-1.17.6-1.el7.x86_64
python-rhsm-1.17.2-1.el7.x86_64

How reproducible:


Steps to Reproduce:
1. Register host to satellite
2. Open satellite webUI, subscribe and check available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)"as the following:

go to Hosts-->Content hosts, click on host, jump to host detail page, go to Subscriptions-->Add, it will show the available pool quantity of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)" under "Attach" tab  is "0 out of 50"(see attachment "before attach"), click on "Add Selected", it will subscribe two pools.

3. In webUI, check the quantity of available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)" is "2 out of 50"(see attachment "after attach")
4. In webUI, Remove the subscribed pool on step2
5. Check the quantity of available pool of "Red Hat Enterprise Linux Server, Premium (Physical or Virtual Nodes)"

Actual results:
It still show "2 out of 50"(see attachment "after remove")

Expected results:
It should show "0 out of 50" since it hasn't been subscribed by any host.

Additional info:

Comment 1 Liushihui 2016-05-25 07:36:00 UTC
Created attachment 1161327 [details]
pool_quantity

Comment 2 Liushihui 2016-05-25 07:43:17 UTC
It hasn't this problem on Satellite6.1.9

Comment 4 John Mitsch 2016-06-13 20:33:19 UTC
Created redmine issue http://projects.theforeman.org/issues/15394 from this bug

Comment 5 Bryan Kearney 2016-06-15 18:15:26 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15394 has been closed

Comment 6 Eko 2016-07-27 05:25:35 UTC
verified with Satellite-6.2.0-RHEL-7-20160725.0
remove the attached pool, the quantity is changed normally.

Comment 7 Bryan Kearney 2016-07-27 11:05:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.