Bug 133955 - Apache UserDir does not work if SELinux is set to Enforcing
Apache UserDir does not work if SELinux is set to Enforcing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: FutureFeature
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-09-28 13:15 EDT by Tero Ojala
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 18:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tero Ojala 2004-09-28 13:15:23 EDT
Description of problem:

Apache's UserDir does not work if SELinux set to Enforcing.


How reproducible:

Configure Apache UserDir. Switch SELinux Enforcing/Permissive. Works
when SELinux is set to Permissive. Does not work with Enforcing.
 

Actual results:

Apache does not serve from www.mysite.com/~user and "(13)permission
denied. access to /~user denied." appears in /var/log/httpd/error_log


Expected results:

Apache serves from ~user/public_html


Additional info:
Comment 1 Daniel Walsh 2004-09-30 14:49:10 EDT
Try
chcon -R -t httpd_user_content_t ~USERNAME/public_html
Comment 2 Ben Levenson 2004-10-06 18:49:27 EDT
This works for me.
* Verify settings in httpd.conf
* Verify file contexts (comment #1)
* Verify directory perms for ~user and ~user/public_html

-> NOTABUG

Note You need to log in before you can comment on or make changes to this bug.