Bug 1339556 - New storage profile on host OSDs not displayed in drop down list
Summary: New storage profile on host OSDs not displayed in drop down list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2
Assignee: kamlesh
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-05-25 10:06 UTC by Lubos Trilety
Modified: 2016-08-23 19:52 UTC (History)
6 users (show)

Fixed In Version: rhscon-core-0.0.41-1.el7scon.x86_64 rhscon-ceph-0.0.40-1.el7scon.x86_64 rhscon-ui-0.0.52-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:52:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
storage profile list (139.67 KB, image/png)
2016-05-25 10:06 UTC, Lubos Trilety
no flags Details
host OSDs tab (84.98 KB, image/png)
2016-08-03 14:39 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Lubos Trilety 2016-05-25 10:06:25 UTC
Created attachment 1161373 [details]
storage profile list

Description of problem:
A new storage profile created during cluster creation is not displayed in 'Storage Profile:' drop down list on host OSDs tab.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.19-1.el7scon.x86_64
rhscon-ceph-0.0.18-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create some cluster, during that create a new storage profile, add some OSDs to the new profile
2. Open the OSDs page for some host which is part of the cluster
3. Check the 'Storage Profile:' drop down list

Actual results:
A newly created storage profile is not part of the list

Expected results:
All storage profiles are listed there, or at least those related with OSDs on the host.

Additional info:

Comment 1 Nishanth Thomas 2016-05-25 10:35:46 UTC
Does this storage profile successfully created in the backend? Can I have access to the system where this can be reproduced?

Comment 2 Lubos Trilety 2016-05-25 13:33:30 UTC
(In reply to Nishanth Thomas from comment #1)
> Does this storage profile successfully created in the backend? Can I have
> access to the system where this can be reproduced?

The new profile is listed correctly on backend.

Comment 3 Nishanth Thomas 2016-06-23 12:41:34 UTC
Need retest with latest build and publish the results

Comment 4 Lubos Trilety 2016-06-23 13:53:27 UTC
Re-test on
rhscon-core-selinux-0.0.26-1.el7scon.noarch
rhscon-ui-0.0.41-1.el7scon.noarch
rhscon-core-0.0.26-1.el7scon.x86_64
rhscon-ceph-0.0.26-1.el7scon.x86_64

still valid

Comment 5 Lubos Trilety 2016-08-03 14:35:22 UTC
Tested on:
rhscon-core-0.0.38-1.el7scon.x86_64
rhscon-ceph-0.0.38-1.el7scon.x86_64
rhscon-core-selinux-0.0.38-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch

I still cannot see any storage profile defined by user in the drop down list on Host - OSDs tab.

Comment 6 Lubos Trilety 2016-08-03 14:39:02 UTC
Created attachment 1187099 [details]
host OSDs tab

user defined test1 profile is missing in the drop down list

Comment 7 Martin Kudlej 2016-08-09 06:52:07 UTC
Tested with
ceph-ansible-1.0.5-32.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.40-1.el7scon.x86_64
rhscon-core-0.0.41-1.el7scon.x86_64
rhscon-core-selinux-0.0.41-1.el7scon.noarch
rhscon-ui-0.0.52-1.el7scon.noarch
and it works.

Comment 9 errata-xmlrpc 2016-08-23 19:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.