Bug 1339575 - "ctrl+alt" still can release cursor after setting --hotkeys=release-cursor=ctrl+alt+a for vnc guest
Summary: "ctrl+alt" still can release cursor after setting --hotkeys=release-cursor=ct...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Grunt
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1342013 1351574
TreeView+ depends on / blocked
 
Reported: 2016-05-25 11:16 UTC by Xiaodai Wang
Modified: 2016-11-04 01:20 UTC (History)
8 users (show)

Fixed In Version: virt-viewer-2.0-8.el7
Doc Type: Bug Fix
Doc Text:
Cause: the default release sequence (ctrl+alt) was not disabled Consequence: both key sequences (the default and the hotkey's one) can be used to release the cursor Fix: disable the default key sequence when another sequence was specified using the --hotkeys option Result: Only the requested sequence is working for releasing the cursor
Clone Of:
: 1342013 1351574 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:20:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 0 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 13:26:58 UTC

Description Xiaodai Wang 2016-05-25 11:16:18 UTC
Description of problem:
"ctrl+alt" still can release cursor after setting --hotkeys=release-cursor=ctrl+alt+a for vnc guest

Version-Release number of selected component (if applicable):
virt-viewer-2.0-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a running vnc guest.
2. Run "virt-viewer -c qemu:///system $guest --hotkeys=release-cursor=ctrl+alt+a".
3. Click the guest to make sure the cursor is grabbed and check the title of the guest has been changed to "(Press Ctrl+Alt+A to release pointer)"
4. Press "ctrl+alt".


Actual results:
The cursor is released after pressing "ctrl+alt".

Expected results:
The cursor should only be released by pressing "ctrl+alt+a".

Additional info:
This is only for vnc guests.

Comment 3 Pavel Grunt 2016-06-02 09:13:01 UTC
Fixed upstream:
bc838038590d2381d440916858a19f334a3ff377

Comment 5 Xiaodai Wang 2016-06-30 09:47:41 UTC
I verified it with virt-viewer-2.0-8.el7.x86_64 following the steps in #comment 0.

Now the cursor can only be released by pressing hotkey which setting in command line.

So move the bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2016-11-04 01:20:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html


Note You need to log in before you can comment on or make changes to this bug.