Bug 133958 - libc-2.3.3.so not accessible on i586
libc-2.3.3.so not accessible on i586
Status: CLOSED DUPLICATE of bug 133505
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2004-09-28 13:50 EDT by Simon Matter
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:05:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2004-09-28 13:50:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914

Description of problem:
There seems to be a problem in the targeted policy which affects my
test server with AMD K6-2 using i586 kernel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC3-test2 on AMD K6-2 CPU
2. Boot the box
3. Check for selinux messages

Actual Results:  Some services don't start because of this:
audit(1096393300.837:0): avc:  denied  { execute } for  pid=1888
path=/lib/tls/i486/libc-2.3.3.so dev=dm-0 ino=38369
scontext=user_u:system_r:syslogd_t tcontext=system_u:object_r:lib_t

Expected Results:  The selinux policy should work on every CPU.

Additional info:

I updated todays package and I saw that there where changes concerning
/lib/tls directories but it still doesn't work for me. I tried to fix
it myself but somehow I just can't get it to work.
Comment 1 Daniel Walsh 2004-09-28 14:24:42 EDT
This is a kernel problem, that will hopefully be solved soon.


*** This bug has been marked as a duplicate of 133505 ***
Comment 2 Simon Matter 2004-09-29 18:14:29 EDT
It seems it wasn't a kernel problem here because upgrading to current
rawhide has fixed it for me without upgrading the kernel.
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.