Bug 1339624 - re-running the quick installer should not prompt a user to re-enter proxy information.
Summary: re-running the quick installer should not prompt a user to re-enter proxy inf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Tim Bielawa
QA Contact: liujia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 13:14 UTC by Eric Rich
Modified: 2017-03-08 18:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: An incorrect variable was being referenced when persisted settings were being fetched. Consequence: Users were forced to re-enter saved proxy information. Fix: The variable reference was corrected. Result: Users no longer have to re-enter proxy information if it has already been saved.
Clone Of:
Environment:
Last Closed: 2016-10-03 14:52:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1983 0 normal SHIPPED_LIVE OpenShift Container Platform 3.3 atomic-openshift-utils bug fix update 2016-10-03 18:51:38 UTC

Description Eric Rich 2016-05-25 13:14:54 UTC
Description of problem:

re-run of quick installer with -c should not ask about proxy information (even if non is provided).

Version-Release number of selected component (if applicable): 3.2


How reproducible: 100%


Steps to Reproduce:
1. Run an install (stop it at any point before it finishes)
2. Re-Run the installer
   # atomic-openshift-installer -c .config/openshift/installer.cfg.yml install 

Actual results: The installer presents you with the pre-requisites, and then asks you to put in http and https proxy information. 

Expected results: The installer should present you with the pre-requisites, and then jump to presenting you with data from the config, and begin checking facts.

Comment 2 Tim Bielawa 2016-08-29 19:01:46 UTC
Patch which fixes this issue has been submitted in this PR:

https://github.com/openshift/openshift-ansible/pull/2379

Comment 3 liujia 2016-09-19 05:19:26 UTC
(In reply to Tim Bielawa from comment #2)
> Patch which fixes this issue has been submitted in this PR:
> 
> https://github.com/openshift/openshift-ansible/pull/2379

Verified on this PR, it worked correctly with no proxy information prompted but jumping to present you with data from the config, and begin checking facts.

BTW, it maybe not only happen when re-install but also when install for the first time as long as install with specific configure file. 

I verified this situation and it will not require user to re-enter info too.

Comment 5 Anping Li 2016-09-20 10:01:41 UTC
Waiting for puddle to verify this bug.

Comment 6 liujia 2016-09-21 03:04:17 UTC
Version:
ansible-2.2.0-0.50.prerelease.el7.noarch
atomic-openshift-utils-3.3.25-1.git.0.56ee824.el7.noarch

Steps:
1, run an install
#atomic-openshift-installer install
2, stop the install after all facts info have been wrote into config and inventory file successfully.
3, re-run an install
#atomic-openshift-installer -c .config/openshift/installer.cfg.yml install

Result:
After prerequisites displayed,it will directly display installation info and then start to check facts with no proxy ensurance.

Comment 8 errata-xmlrpc 2016-10-03 14:52:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1983


Note You need to log in before you can comment on or make changes to this bug.