Bug 1339650 - Unnecessary date/time transformation for sync plan start date
Summary: Unnecessary date/time transformation for sync plan start date
Keywords:
Status: CLOSED DUPLICATE of bug 1335133
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Uncategorized
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 1335133
TreeView+ depends on / blocked
 
Reported: 2016-05-25 14:13 UTC by Walden Raines
Modified: 2019-04-01 20:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1335133
Environment:
Last Closed: 2016-05-25 17:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15181 0 None None None 2016-05-25 15:03:59 UTC

Description Walden Raines 2016-05-25 14:13:19 UTC
This is just for tracking the changes required to bastion required for this fix.

+++ This bug was initially created as a clone of Bug #1335133 +++

Description of problem:
From first glance, transforming date and time for sync plans to Satellite server values can be treated as a feature, but is unacceptable from user perspective. That is fine to have some logic like this, but somewhere internally on the server, not for public view

API example:
Making HTTP POST request to https://server/katello/api/v2/organizations/1850/sync_plans with options {'verify': False, 'auth': ('admin', 'changeme'), 'headers': {'content-type': 'application/json'}} and data {"interval": "hourly", "enabled": false, "organization_id": 1850, "sync_date": "06/07/2372 04:18", "name": "name"}.

Received HTTP 200 response:   {"id":132,"organization_id":1850,"name":"name","description":null,"interval":"hourly","next_sync":null,"created_at":"2016-05-11 10:48:20 UTC","updated_at":"2016-05-11 10:48:20 UTC","enabled":false,"products":[],"permissions":{"view_sync_plans":true,"edit_sync_plans":true,"destroy_sync_plans":true},"sync_date":"07/06/2372 12:18:AM"}

UI example:
Created with '2016-05-11' and '15:09'
and received:
'05/11/2016 08:09:AM'

If API part has not so serious impact, but UI behaviour should be definitely treated as severe issue as for user it is complete mess why his data is transformed in that way.

Version-Release number of selected component (if applicable):
6.2 SNAP 10

How reproducible:
Always

Steps to Reproduce:
1. Create new sync plan with specific start data and time
2. Read the entity back and check the values returned
3.

Actual results:
Data and time is transformed to system time taken from the server where application is deployed

Expected results:
Data and time should be shown in the same format and values as user inputted them

Additional info:
'Start Date' is transformed, but not the 'Next Sync' information that is add even more chaos in sync process

--- Additional comment from Oleksandr Shtaier on 2016-05-11 08:21:25 EDT ---

Blocker for bunch of test automation cases

--- Additional comment from RHEL Product and Program Management on 2016-05-11 08:34:58 EDT ---

Since this issue was entered in Red Hat Bugzilla, the pm_ack has been
set to + automatically for the next planned release

--- Additional comment from Oleksandr Shtaier on 2016-05-11 10:40:54 EDT ---

Regression was introduced pretty recently (I suspect in first GA) as automation started to fail just for last build for that area

--- Additional comment from Walden Raines on 2016-05-12 11:02:17 EDT ---



--- Additional comment from Walden Raines on 2016-05-12 11:02:26 EDT ---



--- Additional comment from Walden Raines on 2016-05-12 11:02:31 EDT ---

Comment 1 Walden Raines 2016-05-25 14:14:53 UTC
Created redmine issue http://projects.theforeman.org/issues/15181 from this bug

Comment 2 Bryan Kearney 2016-05-25 16:17:26 UTC
Upstream bug component is Uncategorized

Comment 5 Walden Raines 2016-05-25 17:39:14 UTC
Closing this in favor of adding foreman trackers to bug #1335133.

*** This bug has been marked as a duplicate of bug 1335133 ***


Note You need to log in before you can comment on or make changes to this bug.