Bug 1339709 - System error message after an attempt to log in with a password containing invalid symbols
System error message after an attempt to log in with a password containing in...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Mac OS
unspecified Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
Yanping Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-25 12:32 EDT by pavlina.vatseva
Modified: 2016-05-31 16:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 16:03:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pavlina.vatseva 2016-05-25 12:32:24 EDT
Description of problem:
While testing log-in process with a password containing question marks ("12345??"), the following error message appeared: "A system error has occurred. If the problem persists, please contact Red Hat support."

How to reproduce:
Unfortunately I could not reproduce it again. I hit the error message approximately between 19:00 and 19:20 on 9 May 2016. I suggest looking at the logs as it may give some additional information on the issue.

Steps to Reproduce:
1. Go to https://www.openshift.com/app/account/new using Chrome browser
2. Enter a valid email address (I used azsumpoly@abv.bg when the error message occurred)
3. Enter 12345?? as a password in the two fields
4. Enter the captcha
5. Hit the "Sign up" button

Actual results:
The error message occured: "A system error has occurred. If the problem persists, please contact Red Hat support."

Expected results:
The registration of the user should have been completed and I should have been redirected to https://www.openshift.com/app/account/complete
Comment 1 Rory Thrasher 2016-05-26 13:15:06 EDT
I was able to successfully create an account using the password `12345??`.  This error may be tied to a connection issue rather than the contents of the password.
Comment 2 Rory Thrasher 2016-05-31 16:03:19 EDT
Pavlina,

It looks like we had some authentication issues around the timeframe that you mentioned.  My guess is that a temporary outage on the OpenShift side may have caused the error.  Given that the problem seems to have been fixed, I'm going to go ahead and close this as works for me.  Please feel free to reopen if it happens again or if you have any additional information.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.