Bug 1339719 - Upgrade from Fedora 23 to Rawhide problem. Conflict with python3-libs file. The system path is not cleared. [NEEDINFO]
Summary: Upgrade from Fedora 23 to Rawhide problem. Conflict with python3-libs file. T...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-25 16:57 UTC by regihop7
Modified: 2016-05-31 09:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-31 09:05:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cstratak: needinfo? (regihop7)


Attachments (Terms of Use)

Description regihop7 2016-05-25 16:57:54 UTC
Description of problem:

A conflict with file from package python3-libs file appears when try to upgrade from Fedora 23 to Rowhide. 


The following error appears:
Total                                                                                                                                                                              948 kB/s |  56 MB     01:00     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/libpython3.so from install of system-python-libs-3.5.1-7.fc25.x86_64 conflicts with file from package python3-libs-3.4.3-6.fc23.x86_64

Error Summary

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Miro Hrončok 2016-05-25 19:57:26 UTC
What is the exact way of upgrading?

Comment 2 Alexander Todorov 2016-05-26 08:49:43 UTC
M(In reply to Miro Hrončok from comment #1)
> What is the exact way of upgrading?

Hi Miro,
from a Fedora 23 system (default install):

1) dnf -y update
2) dnf -y install fedora-repos-rawhide
3) enable the rawhide repos
4) dnf -y update


With the same steps we also see bug #1339731

Comment 3 Miro Hrončok 2016-05-26 10:54:53 UTC
I believe we forgot to add some Conflicts:

https://fedoraproject.org/wiki/Packaging:Conflicts#Splitting_Packages

Comment 4 Charalampos Stratakis 2016-05-30 10:11:08 UTC
Tested it on Friday and I was able to reproduce the problem, however today when I retested on a clean f23 machine and upgraded to rawhide, it worked as expected with no conflicts.

Dnf got updated so maybe somehow it got resolved? Couldn't find something specific in the release notes however.

Could you retest it and tell me if you are still getting this error?

Comment 5 Charalampos Stratakis 2016-05-30 15:04:52 UTC
Ok I isolated some test cases.

A fedora 23 image was used for all systems, updated with dnf as of May 30.

1) # dnf install fedora-repos-rawhide
# dnf update --enablerepo-rawhide --refresh

Updates complete successfully, machine doesn't reboot however due to probably unrelated issue (rawhide kernel?)

Also the same with:
# dnf update --releasever=rawhide --nogpgcheck --refresh # nogpgcheck for unsigned kernel

2) # dnf distro-sync --releasever=24 --refresh

Everything works

3) # dnf install dnf-plugin-system-upgrade
# dnf system-upgrade download --refresh --releasever=24

As documented here [0] and it works also.

4) # dnf update --releasever=24 --refresh
This is where the error appears and also the bug #1339731


[0]https://fedoraproject.org/wiki/DNF_system_upgrade

Comment 6 Miro Hrončok 2016-05-30 17:54:53 UTC
The explicit conflict should solve even potential problems and cannot do any harm (expect when done wrong).

Comment 7 Alexander Todorov 2016-05-31 09:05:52 UTC
I've tested today with the steps from comment #2.  Did not see any conflicts, the resulting system has:

python3-libs-3.5.1-7.fc25.x86_64
system-python-libs-3.5.1-7.fc25.x86_64


Closing.


Note You need to log in before you can comment on or make changes to this bug.