Bug 133990 - keyboard type-ahead broken for menu navigation
keyboard type-ahead broken for menu navigation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 16:45 EDT by Chris Lee
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 08:20:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lee 2004-09-28 16:45:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040928 Firefox/0.10

Description of problem:
When accessing the panel menus, it's nice to be able to start typing
the first few letters of a menu item to be able to jump to it. The
GNOME panel does in fact support this feature, but the user has to
first pop the panel menu open and then activate one of the items
before the type-ahead find works.

As soon as the menu is opened, typing a character on the keyboard
should initiate finding the menu item.

Version-Release number of selected component:
gnome-panel-2.8.0-1

How reproducible:
Always

Steps to Reproduce:
1. Click on a menu
2. Start typing
3. Note that none of the menu items gets activated

Actual Results:  The menu ignores the keys I press until I highlight
one of the menu items.

Expected Results:  The menu should activate whichever menu item I
start typing the string from.
Comment 1 Mark McLoughlin 2004-09-29 10:26:34 EDT
Well, it works for me when I click on the main menu button, so do you
mean:

  1. Click on menu button
  2. Navigate with mouse to open a sub-menu
  3. Hit key, causes another sub-menu to be selected rather
     than a menu item in the sub-menu you've already 
     selected

If so, try the same thing with gedit's "View" menu - this is standard
for all GTK+ menus.

Or am I misunderstanding?
Comment 2 Mark McLoughlin 2004-12-20 08:20:35 EST
No response, closing

Note You need to log in before you can comment on or make changes to this bug.