Bug 133991 - Unable to debug random X failures
Unable to debug random X failures
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-28 16:52 EDT by Matthew Booth
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 17:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2004-09-28 16:52:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I have tried to install RHEL4 beta 1 on 2 different machines now and
experienced X failures. After probing for video, monitor, mouse the X
server fails to start. The two machines have very different hardware,
including different graphics cards (matrox and nvidia). On the second
machine, I ran the installer and X failed, I allowed it to reboot and
did exactly the same again and X did not fail.

I am unable to debug the failures, because immediately they have
occurred anaconda exists. An X log which might give a clue to the
cause is reported to have been written to /tmp/X.log, but I am unable
to access it.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start installing RHEL4 Beta 1.
2. Hope that X fails to start this time.
    

Actual Results:  System exits.

Expected Results:  System allows an opportunity to examine log files
from failed X startup.

Additional info:
Comment 1 Jeremy Katz 2004-09-28 17:11:16 EDT
Booting with 'linux nokill' will let you access things. 
Unfortunately, we have to kill processes to be able to unmount
filessystems and let you reboot cleanly in most cases.

Note You need to log in before you can comment on or make changes to this bug.