Bug 1339978 - Container provider dashboard page cannot load data
Summary: Container provider dashboard page cannot load data
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: GA
: 5.6.0
Assignee: Yaacov Zamir
QA Contact: Einat Pacifici
URL:
Whiteboard: container
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 09:35 UTC by Dafna Ron
Modified: 2018-04-17 07:58 UTC (History)
8 users (show)

Fixed In Version: 5.6.0.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 16:05:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
epacific: automate_bug+


Attachments (Terms of Use)
logs and screenshot (490.19 KB, application/x-gzip)
2016-05-26 09:35 UTC, Dafna Ron
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 0 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Dafna Ron 2016-05-26 09:35:15 UTC
Created attachment 1161833 [details]
logs and screenshot

Description of problem:

Dashboard objects are not loading when pressing the dashboard display under provider 

Version-Release number of selected component (if applicable):

cfme-5.6.0.8-rc1.1.el7cf.x86_64

How reproducible:

100%

Steps to Reproduce:
1. select a provider 
2. change display to dashboard
3.

Actual results:

the objects will not load 

Expected results:

we should view the display as dashboard with all objects loading properly 

Additional info: logs and screenshot

Comment 1 Dafna Ron 2016-05-26 09:36:24 UTC
upstream bug: https://github.com/ManageIQ/manageiq/issues/8953

Zahi made a PR fixing the links in single provider dashboard
https://github.com/ManageIQ/manageiq/pull/8965

Comment 3 Yaacov Zamir 2016-05-26 10:36:33 UTC
Issue https://github.com/ManageIQ/manageiq/issues/8953 is about the link.
This bug is about broken data id.

We need another bug report for the bad links.

A fix for *this* bug is submitted here:
https://github.com/ManageIQ/manageiq/pull/8981

Comment 4 CFME Bot 2016-05-29 03:35:51 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c7e1d646394d9af444735e3fead18a9aaab728f8

commit c7e1d646394d9af444735e3fead18a9aaab728f8
Author:     Yaacov Zamir <yzamir@gmail.com>
AuthorDate: Thu May 26 11:58:20 2016 +0300
Commit:     Yaacov Zamir <yzamir@gmail.com>
CommitDate: Sat May 28 13:57:57 2016 +0300

    Fix the regex that gets the ems_container id.
    
    The regex that collect the ems_container id, fails when url line is an ip.
    When this happen the dashboard page fails to load the correct data.
    
    Bugzilla:
    https://bugzilla.redhat.com/show_bug.cgi?id=1339978

 .../container_dashboard_controller.js              | 14 ++--
 .../container_dashboard_controller_spec.js         | 75 ++++++++++++++++++++--
 2 files changed, 79 insertions(+), 10 deletions(-)

Comment 6 Einat Pacifici 2016-06-07 11:40:07 UTC
Verified. All objects are loaded,viewed and clickable in Providers Dashboard. 
Fixed is 5.6.0.9-rc2

Comment 8 errata-xmlrpc 2016-06-29 16:05:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.