Bug 133998 - SCSI layer crashes on cancel->offline transition in 2.6.x
SCSI layer crashes on cancel->offline transition in 2.6.x
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-09-28 17:33 EDT by Alan Cox
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 05:23:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-09-28 17:33:05 EDT
If you rmmod a scsi driver while it is in error handling the kernel
crashes. Since this failure is lack of support for going from
cancel->offline it looks as if the same bug applies for other
offlining cases otuside of EH caused offlining.

Posted full details to linux-scsi  will see what occurs.
Comment 1 Dave Jones 2005-07-15 16:05:16 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.