Bug 1340025 - v2v: import dialog - invalid error message while opening dialog saying "no Export Domain is active"
Summary: v2v: import dialog - invalid error message while opening dialog saying "no Ex...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.0.4
: 4.0.4
Assignee: Sharon Gratch
QA Contact: Nisim Simsolo
URL:
Whiteboard:
: 1359667 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 10:39 UTC by Sharon Gratch
Modified: 2016-09-26 12:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-26 12:32:38 UTC
oVirt Team: Virt
rule-engine: ovirt-4.0.z+
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
screenshot (28.10 KB, image/png)
2016-05-26 10:39 UTC, Sharon Gratch
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 58744 master MERGED webadmin: v2v-fix message and load button enabling 2016-06-09 10:25:05 UTC
oVirt gerrit 61607 ovirt-engine-4.0 MERGED webadmin: v2v-fix message and load button enabling 2016-07-28 11:45:29 UTC

Description Sharon Gratch 2016-05-26 10:39:35 UTC
Created attachment 1161885 [details]
screenshot

Description of problem:
When opening the "import Virtual Machine(s)" dialog, the following error message always appears on start: "Not available when no Export Domain is active", although an active export domain does exist and active. 

Note that after selecting other source (like VMware) and then re-selecting "Export Domain" source again (without changing anything else), the error disappears.

Version-Release number of selected component (if applicable):
4.0.0 beta

How reproducible:
100%

Steps to Reproduce:
1.make sure there is an active export domain
2.Browse webadmin and open "import" dialog.


Actual results:
an error appears: "Not available when no Export Domain is active"

Expected results:
the error is invalid and shouldn't appear

Additional info:
see attached screenshot.

Comment 1 Sharon Gratch 2016-06-09 12:38:52 UTC
After the bug fix, the dialog behavior is as follows:
1. While opening the dialog - error message and button disabling appears only if no export doamin really exists for that DC.

2. Changing the Source from other source back to be "Export Domain" - no actual verification is done for export domain existence. The previous status is kept and displayed. 

3. Selecting other Data Center for the "export Domain" source - actual verification is done by querying the DB and in case no export Domain exists then an err msg is displayed and "load" button is disabled. 

Furtheremore, this bug fix also cleans the VMs lists after selecting other Data Center.

Comment 2 Michal Skrivanek 2016-07-28 07:58:58 UTC
*** Bug 1359667 has been marked as a duplicate of this bug. ***

Comment 3 Michal Skrivanek 2016-07-28 07:59:58 UTC
let's backport it to 4.0.z

Comment 4 Nisim Simsolo 2016-09-04 12:42:09 UTC
Verified: 
ovirt-engine-4.0.4-0.1.el7ev
vdsm-4.18.12-1.el7ev.x86_64
qemu-kvm-rhev-2.6.0-22.el7.x86_64
libvirt-client-2.0.0-6.el7.x86_64


Note You need to log in before you can comment on or make changes to this bug.