Bug 1340063 - hosts are accepting during cluster importing
Summary: hosts are accepting during cluster importing
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: sankarshan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-05-26 11:57 UTC by Martin Kudlej
Modified: 2016-06-03 09:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-03 09:23:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Kudlej 2016-05-26 11:57:46 UTC
Description of problem:
Available hosts are accepting before user click on "Import" button. I think accepting of nodes should be part of importing process or it should be user action like it is in cluster creation workflow.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-15.el7scon.noarch
ceph-installer-1.0.11-1.el7scon.noarch
rhscon-ceph-0.0.18-1.el7scon.x86_64
rhscon-core-0.0.19-1.el7scon.x86_64
rhscon-ui-0.0.34-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to import cluster
2. user see that hosts are accepted automatically during filling wizard forms

Actual results:
Hosts are automatically accepted without any user action.

Expected results:
User should explicitly accept nodes or accepting of nodes should be done after user submit cluster import action(click on "Import" button).

Comment 1 Nishanth Thomas 2016-06-03 09:23:49 UTC
Only bootstrap get accepted before the import operation triggered. This required because without accepting it cannot get the information about the other nodes in the cluster. Rest of the nodes are accepted when the import is triggered.So this is not a bug and I am going to close this


Note You need to log in before you can comment on or make changes to this bug.